[B2G][Browser] When the user sign in to Tumblr, a OOM occurs

RESOLVED WONTFIX

Status

Firefox OS
Performance
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Petes, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support] [2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8457413 [details]
tb.txt

Description:
When the user sign in to Tumblr.com, the browser crash/OOM occurs

Setup Steps:
1) Flame device is set to 273mb

Repro Steps:
1) Update a Flame device to BuildID: 20140714000202
2) Go to Browser
3) Sign in to Tumblr.com


Actual:
the browser crash/OOM occurs

Expected:
the browser crash/OOM occurs does not occur 

Environmental Variables:
Device: Flame 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Repro frequency: 100%
See attached: video, logcat, https://www.youtube.com/watch?v=ccfjQf-IWi4
(Reporter)

Comment 1

3 years ago
This issue also reproduces on the Flame 2.1 (273mb), Flame 1.4(273mb), Base Image v122, and the Base Image v121-2. The browser crash/oom

Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 1.4(273MB)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140716000202
Gaia: 393d72937727ad20e82b2ff7b13e3d7ff077a9f0
Gecko: 932c37978d37
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Base Image
v122

Environmental Variables:
Device: Flame 1.3
Build ID: 20140616171114
Gaia: e1b7152715072d27e0880cdc6b637f82fa42bf4e
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Base Image
v121-2

Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
__________________________________________________________________________________________________________________________

This issue does not reproduce on the Buri 2.1, Open_C 2.1, Flame 2.0(512mb), Buri 2.0, Open_C 2.0, Buri 1.4 and the Open_C 1.4. the browser crash/OOM occurs does not occur 


Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open_C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.0(512mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 1.4

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140716000202
Gaia: 393d72937727ad20e82b2ff7b13e3d7ff077a9f0
Gecko: 932c37978d37
Version: 30.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open_C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140716000202
Gaia: 393d72937727ad20e82b2ff7b13e3d7ff077a9f0
Gecko: 932c37978d37
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

3 years ago
Component: Gaia::Browser → Performance

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I cannot reproduce this on a 319mb flame running build id: 20140721000201.

Flagging for qawanted to retest on 319mb flame configuration.  If this doesn't repro on a 319mb flame, then this bug should be closed, won't fix.
Keywords: qawanted
Tested with Flame device set to 319mb

This bug does NOT repro on: Flame 2.1, Flame 2.0, Flame 1.4, Buri 2.1

Actual Result: No OOM occurs on Flame device set to 319mb or on a Buri device when logging into Tumblr.com.

Environmental Variables:
Device: Flame Master
Build ID: 20140730045709
Gaia: 25e998814ba89f30fe44cd2fdfbb44d160a04641
Gecko: 08c23f12a43e
Version: 34.0a1 (Master)
Firmware Version: v122
----------------------------------------------
Environmental Variables:
Device: Flame 2.0
Build ID: 20140730063205
Gaia: 3f9323d3b3ae8541fd84125a3b3a136bd018dedc
Gecko: 3fe40fbaee6d
Version: 32.0 (2.0)
Firmware Version: v122
------------------------------------------------
Environmental Variables:
Device: Flame 1.4
Build ID: 20140729033637
Gaia: eb3b185325901d4c04e2d43eb58d90835213bea9
Gecko: aef745c136f9
Version: 30.0 (1.4)
Firmware Version: v122
------------------------------------------------
Environmental Variables:
Device: Buri Master
Build ID: 20140728123640
Gaia: fadfafa17f5175203b8b9457bfb95e5816f54f58
Gecko: 75fe3b8f592c
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.