[b2g][Flame][2.0][FM Radio] Unable to return to headphone mode after using speaker mode during a phone call

RESOLVED DUPLICATE of bug 1038749

Status

Firefox OS
AudioChannel
RESOLVED DUPLICATE of bug 1038749
4 years ago
4 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support] [2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8457628 [details]
logcat_20140716_FMRadio.txt

Description:
When the user selects the direction icon, the app crashes after the page is fully loaded.

Pre-requisite: Have a headphone connected to the device during testing

Repro Steps:
1) Updated Flame to Build ID: 20140715000201.
2) Open FM Radio.
3) Scan and find any working station.
4) While the radio is running, make a call from another device.
5) Answer the incoming call, and enable the spearker mode.
6) End the phone call.
7) Observe the FM Radio app resumes. Turn the spearker mode on FM Radio multiple times.

Actual:
The FM Radio resumes in speacker mode, and the user is unable to switch to headphone mode after ending the call.

Expected:
The FM Radio resumes in headphone mode, and the user is able to switch between headphone and speaker mode.

Flame 2.0 (273mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 100%
See attached: video, logcat
http://youtu.be/r7F8hjCCG2Y
(Reporter)

Comment 1

4 years ago
This issue also reproduces on Flame 2.0 (512mb), Flame 2.1 (273mb), Open C 2.1, Open C 2.0:

Flame 2.0 (512mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The user is unable to switch to headphone mode after ending the call.
================================
This issue does NOT reproduce on Flame 1.4 (273mb), Buri 1.4:

Flame 1.4 (273mb)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140716000202
Gaia: 393d72937727ad20e82b2ff7b13e3d7ff077a9f0
Gecko: 932c37978d37
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4

1.4 Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140716000202
Gaia: 393d72937727ad20e82b2ff7b13e3d7ff077a9f0
Gecko: 932c37978d37
Version: 30.0
Firmware Version: v1.2-device.cfg

The FM Radio resumes in headphone mode, and the user is able to switch between headphone and speaker mode.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

4 years ago
Unable to verify on Buri 2.1, Buri 2.0. The audio does not resume at all after ending the phone call and going back to the FM Radio app.

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Comment 3

4 years ago
Correction:
The Description on comment 0 is incorrect. The correct description:

When the user ends a phone call after using speaker mode, the FM Radio resumes in speaker mode, instead of headphone mode. The user is unable to switch back to headphone mode.

Sorry about that.
(Reporter)

Updated

4 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86 → ARM
This is a regression from the Flame 1.4. Nominating this 2.0? since the user cannot switch FM Radio back to the headset. This would frustrate the end user since the music would be coming out of the speaker.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
QA Contact: ckreinbring

Comment 5

4 years ago
Looks like a audiochannel/speaker manager issue. Steven, could you please help investigate

Thanks
Hema
Component: Gaia::FMRadio → AudioChannel
Flags: needinfo?(slee)
Regression window:

Last working
Build ID: 20140714073807
Gaia: 726ca25ef1dbb83d8ed8a902b46fb340a3f95927
Gecko: 53075e07875f
Platform Version: 32.0a2
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First broken
Build ID: 20140714092709
Gaia: a867ab091d8f01b9c68f420ca97e880e06e25871
Gecko: f46aafca1200
Platform Version: 32.0a2
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Working Gaia / Broken Gecko = No repro
Broken Gaia / Working Gecko = Repro
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/726ca25ef1dbb83d8ed8a902b46fb340a3f95927...a867ab091d8f01b9c68f420ca97e880e06e25871


B2G-Inbound regression window:

Last working
Build ID: 20140714035114
Gaia: 2038b76e5bd4632d12944f9b3d835314fec9de39
Gecko: 189d66b64dfd
Platform Version: 33.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First broken
Build ID: 20140714042214
Gaia: ee645d7d0306d972cb3e1f9482278ffbf5e49c46
Gecko: eb677df545a2
Platform Version: 33.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Working Gaia / Broken Gecko = No repro
Broken Gaia / Working Gecko = Repro
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/2038b76e5bd4632d12944f9b3d835314fec9de39...ee645d7d0306d972cb3e1f9482278ffbf5e49c46
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
pushlog results:  possibly broken by bug 1016277 ?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(josea.olivera)

Comment 8

4 years ago
Hi Eric,

Please help this problem. 
Thanks.
Flags: needinfo?(slee) → needinfo?(echou)

Comment 9

4 years ago
It looks like duplication of bug 1038749.  According to comment 17 of bug 1038749, the root cause is the AudioContext of telephony channel is not release correctly. It causes the telephony audio channel occupy the output device (ex. Speaker) so FM stream can not switch to headphone mode. I will print log to get more evidence for this issue.
Flags: needinfo?(echou)
Clearing ni? as comment 9 pointed to the issue.
Flags: needinfo?(josea.olivera)
(Ringer is coming)
I/Cubeb_OpenSL [Star]( 1418): init - stream_type 2 (CUBEB_STREAM_TYPE_RING)

(answer the call)
I/Cubeb_OpenSL [Star]( 1418): destroy - stream_type 2 (CUBEB_STREAM_TYPE_RING)
I/Cubeb_OpenSL [Star]( 1418): init - stream_type 0 (CUBEB_STREAM_TYPE_VOICE_CALL)

(end the call)

In this log, I can't see any stream_type 0 (CUBEB_STREAM_TYPE_VOICE_CALL) was destroyed. The root cause is the same as bug 1038749. I mark this as the duplicate of bug 1038749.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038749
You need to log in before you can comment on or make changes to this bug.