[b2g][Flame][2.0][Rocket Bar] Keyword & results clear when pressing return key or home button.

RESOLVED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Search
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: daleharvey)

Tracking

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 affected, b2g-v2.1 verified)

Details

(Whiteboard: [273MB-Flame-Support] [2.0-exploratory][systemsfe], URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8457664 [details]
logcat_20140716_RocketBar.txt

Description:
Rocket bar clears when the user press return key or home button.  

Repro Steps:
1) Updated Flame to Build ID: 20140715000201.
2) Make sure the Flame device is set to 273mb.
3) Type any keyword in the rocket bar.
4) When the result is loaded, press return key or home button.
5) On the homescreen, tap on the Rocket bar.
6) Observe the search screen.

Actual:
The search term and results are cleared.

Expected:
The search term and results remain.

Flame 2.0 (273mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 100%
See attached: video, logcat
http://youtu.be/D8Izo6nt6DA
(Reporter)

Comment 1

4 years ago
This issue also reproduces on Flame 2.1 (273mb):

Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

The search term and results are cleared.
=============================================================
This issue does NOT reproduce on Flame 2.0 (512mb), Buri 2.1, Buri 2.0, Open C 2.1, Open C 2.0:

Flame 2.0 (512mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140716040207
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: 691ffea49efb
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140716000201
Gaia: 5f8b1b8a2da9e3b531eee817a669f57fa4d9b9c6
Gecko: 913827496f65
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The search term and results remain.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

4 years ago
Rocket bar is not a part of v.1.4. E.me has history function instead and a different layout. 

Flame 1.4 (273mb)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140716000202
Gaia: 393d72937727ad20e82b2ff7b13e3d7ff077a9f0
Gecko: 932c37978d37
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Nominating as a 2.0 blocker since the behavior differs on a same given version.
blocking-b2g: --- → 2.0?
(In reply to Johan Lorenzo [:jlorenzo] from comment #3)
> Nominating as a 2.0 blocker since the behavior differs on a same given
> version.

This only happens on 2.0 and 2.1 with limited memory and the new homescreen right?
We probably kill the search app when we launch the homescreen. So the behavior is based on the fact that we kill the search app.
Flags: needinfo?(kgrandon)
Dale - could you also take a look at this?
Component: Gaia::Everything.me → Gaia::Search
Flags: needinfo?(kgrandon) → needinfo?(dale)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Since the feature didn't exist on 1.4 please do not mark the 1.4 tracking flag. This could cause confusion. Please fix.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(ychung)
Will do
Assignee: nobody → dale
Flags: needinfo?(dale)
So renominating this for blocking and suggesting not to, this isnt a bug so much as a common behaviour across background applications when they are killed with active data, persisting the search could happen either automatically via session restore, there is also open bugs to persist the history of searches which is a new feature and imo the correct fix for this.
blocking-b2g: 2.0+ → 2.0?
Created attachment 8458635 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/21923

Im still 50/50 about blocking, but theres a fairly simple fix for this
Attachment #8458635 - Flags: review?(kgrandon)
I wouldn't hold the release for it. Lets ask for approval.
blocking-b2g: 2.0? → -
Comment on attachment 8458635 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/21923

R+ for now, but spend a few minutes to see if we can write a unit test if possible.

I think something like setting the input content, dispatching a searchterminated event, then checking the input content would be ideal - though I could also live with a simple sinon.notCalled() type of thing. Thanks Dale!
Attachment #8458635 - Flags: review?(kgrandon) → review+
Updated to include a unit test, will land when I see green
landed on master: https://github.com/mozilla-b2g/gaia/commit/f9bcde84ebdbd000eb8bb2289750c5457111f6c8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
status-b2g-v1.4: unaffected → ---
Flags: needinfo?(ychung) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [273MB-Flame-Support] [2.0-exploratory] → [273MB-Flame-Support] [2.0-exploratory][systemsfe]
Target Milestone: --- → 2.0 S6 (18july)
QA Whiteboard: [QAnalyst-Triage+] → [VH-FL-blocking-][VH-FC-blocking-][QAnalyst-Triage+]
status-b2g-v2.1: affected → fixed

Comment 15

3 years ago
This issue has been verified successfully on Flame 2.1

See attachment: Verify_video.3gp
Reproducing rate: 0/5
flame2.1 build:
Gaia-Rev        5655269098c7e82254e56933f1af05b4abe2a2f3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86608c9389b5
Build-ID        20141204001201
Version         34.0
status-b2g-v2.1: fixed → verified

Comment 16

3 years ago
Created attachment 8532382 [details]
Verify_video.3gp
You need to log in before you can comment on or make changes to this bug.