Closed Bug 1039861 Opened 6 years ago Closed 6 years ago

Exterminate the last remnants of OS.File from Apps code

Categories

(Core Graveyard :: DOM: Apps, defect, P1, blocker)

defect

Tracking

(firefox31 wontfix, firefox32 affected, firefox33 fixed, b2g-v2.0 affected, b2g-v2.1 fixed)

RESOLVED FIXED
mozilla33
Tracking Status
firefox31 --- wontfix
firefox32 --- affected
firefox33 --- fixed
b2g-v2.0 --- affected
b2g-v2.1 --- fixed

People

(Reporter: khuey, Assigned: khuey)

References

Details

(Keywords: memory-footprint, perf, Whiteboard: [c=memory p= s= u=2.0])

Attachments

(1 file)

Attached patch PatchSplinter Review
This stops us from loading it in child processes on 2.0.
Attachment #8457680 - Flags: review?(fabrice)
See bug 1005120, I don't know if the situation has changed since then.
Yep, we need a try build first.
Attachment #8457680 - Flags: review?(fabrice) → review+
Severity: normal → blocker
Keywords: perf
Priority: -- → P1
Whiteboard: [c=memory p= s= u=2.0]
https://hg.mozilla.org/mozilla-central/rev/e805b9fb4758
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Duplicate of this bug: 1005120
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #8)
> Backed out from Aurora for mass test bustage.
> https://hg.mozilla.org/releases/mozilla-aurora/rev/dfeac3d29b5e
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=44181994&tree=Mozilla-Aurora

Probably the same problem we were experiencing in bug 1005120. I wonder what fixed it.
blocking-b2g: 2.0+ → ---
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.