All users were logged out of Bugzilla on October 13th, 2018

tables with relative widths not displayed correct

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: mozilla2007, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011009
BuildID:    

try to put two (ore more) tables next to each other: 
1st <table width="2*" align="left">
2nd <table width="8*" align="right">
you should get the same result as 
1st <table width="20%" align="left">
2nd <table width="80%" align="right">

Reproducible: Always
See the followin piece of html

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 //EN"
"http://www.w3.org/TR/html4/strict.dtd">

<html>
  <head>
    <title>mozilla table-test</title>
  </head>

  <body>
    <h1>mozilla test</h1>
    
    <h3>relative lengths</h3>

    <p>
    <table width="2*" align="left" border="3">
      <tr><td>test left</td></tr>
    </table>

    <table width="8*" align="right" border="3">
      <tr><td>test test test test test test test test test test test test test
test test test test test test test test test
	  test test test test test test test test test test test test test test test test
test test test test test test test 
	    test test test test test test test test test test</td></tr>
    </table>
    </p>

    <p>
    <h3>lengths in percentages</h3>

    <table width="20%" align="left" border="3">
      <tr><td>test left</td></tr>
    </table>

    <table width="80%" align="right" border="3">
      <tr><td>test test test test test test test test test test test test test
test test test test test test test test test
	  test test test test test test test test test test test test test test test test
test test test test test test test 
	    test test test test test test test test test test</td></tr>
    </table>
    </p>

  </body>
</html>

Comment 1

17 years ago
create as an attachment and mark keyword: testcase
(Reporter)

Comment 2

17 years ago
somehow I'm not able to create a new attachment from my Linux-machine "No file
was provided, or it was empty." :-(
Put it on my webspace, maybe someone else could do that...
here it is:
http://studhome.rrze.uni-erlangen.de/~simamult/test/table_test.html
sorry... Markus

Comment 3

17 years ago
I guess this bug is invalid, table width is %Length and  not Multilength. Only
col and colgroups should accept "2*" widths. Please look to the HTML4.01 spec.
We will even remove from the content parser the ability to look for * arguments.
(Reporter)

Comment 4

17 years ago
Yes, you're right, got a little confused with the spec. 
I agree to resolve it as invalid. 
remove testcase from my webspace.
btw: This was one of the things, N4.7 displayed without any problems
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
My NN4.7 does not render this correctly, could you attach a screenshot of the
rendering? I am seriously concerned as I am working on bug 97027. IMHO mozilla
already renders this better than NN4.7.

Bernd
(Reporter)

Comment 6

17 years ago
I'm quite sorry, NN4.7 only renders the first pair of tables "correct", and only
if you're using floating-point values (why floating-points??? this should be
ints), e.g. 
<table width="0.2" align="left">
...
</table>
<table width="0.8" align="right">
...
</table>

The second pair of tables looks quite ugly in NN4.7. Sorry because of the
confusion, I just played around yesterday night... 

Markus
You need to log in before you can comment on or make changes to this bug.