bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Overscroll freezes when used on a scrollgrab element with a non-scrollable child

RESOLVED DUPLICATE of bug 1040226

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1040226
4 years ago
4 years ago

People

(Reporter: benfrancis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Video of issue: https://www.youtube.com/watch?v=Dzx7incs3Lw

STR:
* Create an outer scrollable div with an inner iframe navigated to a page that doesn't scroll (note scrollgrab is only enabled for certified apps)

<div id="wrapper>
  <iframe src="http://chrislord.net/files/mozilla/clipping.html">
</div>

wrapper.scrollgrab = true;

#wrapper {
  overflow: scroll;
}

* Scroll inner frame


Alternative STR:
* Apply Gaia patch from bug 1039519 (or checkout Gaia feature branch at https://github.com/benfrancis/gaia/tree/1039519).
* Build Gaia with HAIDA=1 (warning: the UI in this build is going to look pretty broken, but will allow you to reproduce this bug).
* Tap the Rocketbar
* Type http://chrislord.net/files/mozilla/clipping.html
* Wait for page to load
* Overscroll the iframe
* Lift finger

Expected:
* Pretty overscroll

Actual:
* iframe freezes mid-scroll
This is possibly the same issue as bug 1040226 (in which case it's not specific to scrollgrab, but affects all instances of overscrolling after scroll handoff).
See Also: → bug 1040226

Comment 2

4 years ago
The patch on bug 1040226 fixes this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1040226

Updated

4 years ago
Blocks: 1046332
You need to log in before you can comment on or make changes to this bug.