[B2G] Unable to detect or use Data Connection when enabled

RESOLVED DUPLICATE of bug 1040700

Status

RESOLVED DUPLICATE of bug 1040700
4 years ago
4 years ago

People

(Reporter: pbylenga, Assigned: frsela)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 affected, b2g-v2.1 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8458144 [details]
log.txt

Description:
User is unable to use cellular data when it's enabled.


Repro Steps:
1) Update a Flame to 20140717000201
2) Navigate to Settings and Enable Cellular Data with WiFi off
3) Launch Browser and try to navigate to an existing page

Actual:
Page does not render and user is informed they need to have a Data Connection

Expected:
Page renders content and detects that user enabled a Data Connection

Environmental Variables:
Device: Flame 2.0
Build ID: 20140717000201
Gaia: aa4f795b81c6147d67c4f06009e166debcf8856e
Gecko: 0ec0b9ac39f0
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Notes:
Was written in response to bug 1039545

Repro frequency: 10/10, 100%
See attached: logcat
(Reporter)

Comment 1

4 years ago
Issue reproduces on Master.  This was working previously, requesting a window.

Environmental Variables:
Device: Flame Master
Build ID: 20140717040202
Gaia: Unknown
Gecko: a74600665875
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
blocking-b2g: --- → 2.0?
Keywords: qaurgent, regression, regressionwindow-wanted
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
Build ID: 20140714233638
Gaia: a35527a3e3cd44e2586adbd207da5a36b9407aa6
Gecko: 07d3c7056a9a
Version: 33.0a1 (Master)
Firmware Version: v122

First Broken Environmental Variables:
Device: Flame
Build ID: 20140715003139
Gaia: f0d9c5b39735bcbc63405281642437d4fc186cdb
Gecko: 483a4b001065
Version: 33.0a1 (Master)
Firmware Version: v122

First broken gecko & last working gaia - issue does NOT reproduce
Gaia: a35527a3e3cd44e2586adbd207da5a36b9407aa6
Gecko: 483a4b001065

First broken gaia & last working gecko - issue DOES reproduce
Gaia: f0d9c5b39735bcbc63405281642437d4fc186cdb
Gecko: 07d3c7056a9a

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/a35527a3e3cd44e2586adbd207da5a36b9407aa6...f0d9c5b39735bcbc63405281642437d4fc186cdb

Possibly caused by Bug 965826 ?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, regressionwindow-wanted
possibly broke by Bug 965826 ?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(alberto.crespellperez)
SIM data works for me : 
Gecko     https://hg.mozilla.org/mozilla-central/rev/a74600665875
BuildID   20140717040202
Version   33.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
flame

Please make sure you just didn't drop wifi as the network switching has some gecko bugs:
https://bugzilla.mozilla.org/show_bug.cgi?id=879793 has only landed on central.
https://bugzilla.mozilla.org/show_bug.cgi?id=939318 hasn't landed on either.
I tested by enabling Data during FTU and everything else left untouched in FTU.
The bug is 100% reproducible for me when finding the window.
Turns out that it's the AT&T sim.  I tried with T-mobile and mobile data works with T-Mobile SIM.  With AT&T sim it doesn't work.

Comment 8

4 years ago
Device use "nxtgenphone" apn to setup data call, but network responses an error, "ServiceOptionNotSubscribedError". It seems something wrong in apn setting.

===
07-17 10:26:50.279: I/Gecko(1577): RIL Worker: [0] Handling parcel as REQUEST_SETUP_DATA_CALL
07-17 10:26:50.279: I/Gecko(1577): -*- RadioInterface[0]: Received message from worker: {"status":33,"suggestedRetryTime":-1,"cid":"0","active":0,"type":"","ifname":"","addresses":[],"dnses":[],"gateways":[],"apn":"nxtgenphone","rilMessageType":"datacallerror","errorMsg":"ServiceOptionNotSubscribedError","rilMessageClientId":0}
07-17 10:26:50.279: I/Gecko(1577): -*- DataCall[0:nxtgenphone]: Data call error on APN: nxtgenphone
===
blocking-b2g: 2.0? → 2.0+
Assignee: nobody → frsela

Comment 9

4 years ago
According to comment #7, it seems a regression of gaia, so changes component to Gaia.
Component: RIL → Gaia

Comment 10

4 years ago
Created bug 1040700 in order to restore ATT APN configuration.
Depends on: 1040700
Flags: needinfo?(alberto.crespellperez)
Created attachment 8458593 [details] [diff] [review]
Workaround to fix the issue

Instead backout the last APN database update which introduced this regression since the database we rely on changed the ATT parameters [1][2], this patch can fix the ATT failure.

We hope Google or ATT fix it for the next update.

[1] https://android.googlesource.com/device/sample/+/fcecb7c4de29b518e03667dae3a2cb4675b41a84/etc/apns-full-conf.xml
[2] https://android-review.googlesource.com/#/c/95380/
Attachment #8458593 - Flags: feedback?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1040700

Updated

4 years ago
No longer depends on: 1040700
You need to log in before you can comment on or make changes to this bug.