Giant class file on loading SwingSet demo sample

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED INVALID
17 years ago
8 years ago

People

(Reporter: Hayo Schmidt, Assigned: Joe Chou)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When loading the demo page
http://192.18.97.35/products/plugin/1.3.0_01/demos/jfc/SwingSet2/SwingSet2.html
a file swingset.class is downloaded, that is stored in C:\Dokumente und
Einstellungen\hschmidt\Anwendungsdaten\Mozilla\Profiles\default\zguf8gc6.slt\plugtmp
on my machine.
This file reached a size of 2.393.816 KB, until my partition was completely
full (2.4 GigaBytes, really!). This is a severe problem because it might
have blocked internet access for other users in the network.

Comment 1

17 years ago
.
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir
-> OJI
Assignee: av → edburns
Component: Plug-ins → OJI
QA Contact: shrir → pmac

Comment 3

17 years ago
...trying to reassign again....

Reporter: This works for me using 0.9.4 and the JRE 1.4 plugin on W2K. 
Assignee: edburns → joe.chou
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
In contrary to Peter Lubczynski i used an austrian "Mozilla/5.0 (Windows; U; 
Windows NT 5.0; de-AT; rv:0.9.4) Gecko/20010913" and the JRE 1.3.0_01 .
The phenomenon is still repeatable. This time i preferred to kill Mozilla, when 
the file reached 240 Megabytes.

Comment 5

17 years ago
I downloaded and installed following mozilla builds:
Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:0.9.4) Gecko/20010913
Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:0.9.5) Gecko/20011011
and used JRE 1.3.0_01 on win2k server.

The applet works fine. 

Comment 6

16 years ago
I think this is not a bug.

I use 
Mozilla 1.1a+
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020716
and Java(TM) Plug-in: 1.3.1_03

the applet works well.

the SwingSet2.jar file that has been cached into local disk is only 1.29 MB

Comment 7

16 years ago
not a bug
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 8

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.