Feed Preview should show what feed elements will be shown above the fold

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: chuck)

Tracking

x86
Mac OS X
Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/curate/feed
2. Select Germany from 'Select a Feed to Modify'
3. Notice the Feed Preview

observed behavior:
If the feed elements has multiple elements, we need a way to see how it looks on a mobile phone, particularly what shows up above the fold.

I realize that we will have different screensizes but listing elements in an endless scroll is not useful

This is specifically of interest given that elements above the fold will probably get the most clicks.
(Assignee)

Comment 1

4 years ago
Created attachment 8458212 [details]
Screen Shot 2014-07-17 at 2.33.53 PM.png

As part of the UX sweep I'm doing, I'm changing the experience of the preview to look something like the attached.

When creating or editing a feed item, you will see two different previews:

- The view of the feed item on the feed
- The view of the feed item on its detail view

The former will be a short height to save screen space, the latter will be fixed to ~450px, to simulate a mobile device.

When previewing a feed, it will also be called at ~450px to simulate a mobile device. It will still have the endless scroll, but it will be within a fixed height container.

That should address this bug, so I'll grab it.
(Assignee)

Updated

4 years ago
Assignee: nobody → charmston
(Reporter)

Comment 2

4 years ago
Looks like the redesign didn't address this issue. See  https://www.dropbox.com/s/00hdyw3qeiovbzu/Screenshot%202014-07-21%2015.44.14.png

OR load  the feed for RoW
(Assignee)

Comment 3

4 years ago
1040303https://github.com/mozilla/transonic/compare/e8171b58b03f...46afd73520c3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Contact: charmston
Resolution: --- → FIXED
(Reporter)

Comment 4

4 years ago
We kinda show the preview within the phone chrome now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.