[Flame] Unable to set up FX Account when device is set to Italian (cannot type in field)

RESOLVED DUPLICATE of bug 970022

Status

Firefox OS
FxA
RESOLVED DUPLICATE of bug 970022
4 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Flame, while running:

Gaia   aa4f795b81c6147d67c4f06009e166debcf8856e
SourceStamp 0ec0b9ac39f0
BuildID 20140717000201
Version 32.0a2
Base image: 122 + fonts

STR:
1. Set up device according to https://wiki.mozilla.org/User_Services/Try_FMD
2. During FTU select Italian as the language
3. When you get to the FX Account screen attempt to type something in the field

Expected: I could type in the field
Actual: I cannot type anything in the field, therefore I cannot use the FMD feature

E/GeckoConsole( 1090): Content JS ERROR at app://settings.gaiamobile.org/js/firefox_accounts/panel.js:1 in o: FxaPanel: Error getting Firefox Account: undefined
E/GeckoConsole(  317): Content JS WARN at app://system.gaiamobile.org/js/keyboard_manager.js:515 in km_setKeyboardToShow: trying to set a layout group to show that doesnt exist

Need to see if this affects other locales as well.
Just checked French locale and it seems to work there.
Using it daily without issues, but with my own build that includes the Italian keyboard.

Could it be that you're hitting the usual bug with keyboard not being available and not falling back to English? Does the keyboard work, for example to set-up Wi-Fi?
flod: I cannot get the keyboard to work in other apps, including Contacts.

Once I enabled the English keyboard in Settings, it works. But I guess I am puzzled why in the Italian locale I had to do that and in the other ones I tested I didn't (Polish and French).
Keyboard layouts must be added at build time, since bug 884752.

So, you set Italian in FTU, Gaia searches for "it.js", doesn't found it, and doesn't fall back to "en.js" layout either. That should probably be bug 970022.
Sounds like we can close this as a dupe of bug 970022?
Marcia - I think what happened here is that the build you have doesn't include the Italian keyboard layout, which results in the Italian keyboard being non-functional for input fields.

Do you agree? Or do you think there's a different cause here?
Flags: needinfo?(mozillamarcia.knous)
Agree with jsmith's Comment 6. Duping to Bug 970022
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → DUPLICATE
Duplicate of bug: 970022

Updated

4 years ago
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.