[SingleVariant] When a valid SIM is not present on the first boot, do not configure any setting

RESOLVED FIXED in 2.0 S6 (18july)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: macajc, Assigned: macajc)

Tracking

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
fabrice
: review+
Details | Review
Currently there are some cases where it might be possible, on a single variant build, to overwrite a user's change of some of the SV controlled settings, if he boots without a SIM, makes some changes and after that inserts a valid SIM. To avoid this, it has been decided to not make any setting changes if a valid SIM is not present during the first boot

Here we're changing the behavior of bugs:
891730 - [User Story] Ringtone Runtime Customization by SIM
891729 - [User Story] Wallpaper Runtime Customization by SIM
923455 - [User Story] Single variant: Predictive text configurable by SIM
Depends on: 1026381
Assignee: nobody → carmen.jimenezcabezas
Posted file V1 Proposed patch
Attachment #8458330 - Flags: review?(jmcf)
Comment on attachment 8458330 [details] [review]
V1 Proposed patch

Stealing review. r=me with minor nits fixed.
Attachment #8458330 - Flags: review?(jmcf) → review+
Thanks a lot! I've done the changes and requesting approval while waiting for travis to finish!
Comment on attachment 8458330 [details] [review]
V1 Proposed patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 891730, 891729 and 923455.
[User impact] if declined: In some cases some of the user's decision could be overwritten by the single variant configuration. This means that user settings changes could be undone.
[Testing completed]: Unit tests and manual testing.
[Risk to taking this patch] (and alternatives if risky): Low, it just affects the single variant configuration.
[String changes made]: None
Attachment #8458330 - Flags: approval-gaia-v2.0?
https://github.com/mozilla-b2g/gaia/commit/f217d27dbc2079a64fc2f8f778e133099d06e704
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S6 (18july)
Attachment #8458330 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
You need to log in before you can comment on or make changes to this bug.