[B2G][SMS] User is unable to send an MMS

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Josh Schmitt [Joshs], Assigned: albert)

Tracking

({regression, smoketest})

unspecified
2.1 S1 (1aug)
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [273MB-Flame-Support])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8458307 [details]
log.txt

Description:

Unable to send an MMS

Repro Steps:
1. Update a Flame to 20140717000201
2. Open SMS app
3. Create a new sms thread
4) Add a real phone number to the recipient list
5) Select the Attach button
6) Select Gallery > Select a picture
7) Select Done to cropping and send the MMS

Actual Results:
Message does not send.

Expected Results:
MMS to send to the recipient in a timely manner.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140717000201
Gaia: aa4f795b81c6147d67c4f06009e166debcf8856e
Gecko: 0ec0b9ac39f0
Version: 32.0a2 (2.0)
Firmware Version: v122

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 100%
See attached: logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
Summary: [B2G][SMS] User is unable to send MMS → [B2G][SMS] User is unable to send an MMS
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
The regression window is the same as bug 1040211.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
This should get resolved by the back out of Bug 965826; I tested the revert and I was able to send SMS via AT&T sim following.
Flags: needinfo?(alberto.crespellperez)
Can we please backout bug 965826 ?
Blocks: 965826
Component: Gaia::SMS → Gaia
Keywords: checkin-needed
(Assignee)

Comment 4

4 years ago
(In reply to Julien Wajsberg [:julienw] from comment #3)
> Can we please backout bug 965826 ?

No, we need bug 965826 because is necessary to pass certification process in Germany.

Created bug 1040700 as a followup to restore ATT APN an keep O2 configuration
Flags: needinfo?(alberto.crespellperez)
(Assignee)

Comment 5

4 years ago
Removing checkin-needed and adding dependency that will fix the ATT APN configuration
Depends on: 1040700
Keywords: checkin-needed
(In reply to Albert [:albert] from comment #4)
> (In reply to Julien Wajsberg [:julienw] from comment #3)
> > Can we please backout bug 965826 ?
> 
> No, we need bug 965826 because is necessary to pass certification process in
> Germany.

I didn't mean to backout it for good, but only as a temporary measure until you can look at the issue.

Is this bug fixed now that bug 1040700 is fixed?
(In reply to Julien Wajsberg [:julienw] from comment #6)
> (In reply to Albert [:albert] from comment #4)
> > (In reply to Julien Wajsberg [:julienw] from comment #3)
> > > Can we please backout bug 965826 ?
> > 
> > No, we need bug 965826 because is necessary to pass certification process in
> > Germany.
> 
> I didn't mean to backout it for good, but only as a temporary measure until
> you can look at the issue.

Moreover, I asked the backout on 18th July, it would have been backed out from both master and v2.0.
Now it's fixed on master but not in v2.0 yet. It won't likely be fixed on v2.0 until today or even maybe tomorrow (depending on when triages happen and when sheriffs do the uplift process). Which means a build with the fix won't likely exist for users until tonight or tomorrow night (US time). Until then, AT&T users can't send MMS.

A backout is not a bad thing, it's a way to make things work again.
Going to assume this is fixed by the dependency landing. If that ends up not being the case, then reopen.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
status-b2g-v2.1: --- → fixed
Assignee: nobody → alberto.crespellperez
status-b2g-v2.0: affected → fixed
Target Milestone: --- → 2.1 S1 (1aug)
(Reporter)

Comment 9

4 years ago
Verified fixed on 2.1 Flame 319MB and 2.0 Flame 319MB.

I am able to send an MMS after cropping a Gallery picture.

Enviromental Variables:
----------------------------------------
Device: Flame 2.1
BuildID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
----------------------------------------------
Device: Flame 2.0
BuildID: 20140905000204
Gaia: 4627014cc5c5eeec894183866d4c57291302f8b8
Gecko: 2fae20afe1fa
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.