The default bug view has changed. See this FAQ.

Include Android panda run_file_names in in-tree mozharness configs

RESOLVED DUPLICATE of bug 1070041

Status

Release Engineering
Mozharness
RESOLVED DUPLICATE of bug 1070041
3 years ago
2 years ago

People

(Reporter: nalexander, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
At the moment, the names of scripts such as runtestsremote.py are in mozharness:

http://mxr.mozilla.org/build/source/mozharness/configs/android/android_panda_releng.py

It would make it easier for me to experiment with new test harness code on try if they were in-tree, at:

http://mxr.mozilla.org/mozilla-central/source/testing/config/mozharness/android_panda_config.py

(The script locations are in-tree for tegras.)
+1

Just to note that because mozharness operates across branches, moving configs in-tree means we either have to:

1) Land the m-c change on every branch that runs in tbpl, or
2) Duplicate the configs in-tree and in mozharness, and have the mozharness script fallback if the in-tree one doesn't exist.
(Reporter)

Updated

3 years ago
Depends on: 1064002
Assignee: nobody → armenzg
QA Contact: escapewindow+mozbugs → jlund
Blocks: 1067535
There's no dependency on bug 1064002.
No longer depends on: 1064002
I'm going to use bug 1070041 to tackle this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1070041
Code has landed in bug 1070041 which add run_filename for panda jobs.
http://hg.mozilla.org/mozilla-central/file/9bb8b0b4daae/testing/config/mozharness/android_panda_config.py
You need to log in before you can comment on or make changes to this bug.