[B2G][Browser] When the user goes to pizzahut.co.in, the desktop page loads which causes a OOM

RESOLVED WONTFIX

Status

Firefox OS
Performance
P3
normal
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: Petes, Unassigned)

Tracking

({perf})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:-, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support], [2.0-exploratory][c=memory p= s= u=], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8458309 [details]
ph.txt

Description:
When the user goes to pizzahut.co.in, the desktop page loads which causes the browser to crash/OOM occurs

Setup Steps:
1) Flame device is set to 273mb

Repro Steps:
1) Update a Flame device to BuildID: 20140717000201
2) Go to Browser
3) Go to pizzahut.co.in
4) Tap order online
5) Zoom in on the layout 


Actual:
the browser crash/OOM occurs

Expected:
the browser crash/OOM occurs does not occur 

Environmental Variables:
Device: Flame 2.0
Build ID: 20140717000201
Gaia: aa4f795b81c6147d67c4f06009e166debcf8856e
Gecko: 0ec0b9ac39f0
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32

Notes: oom occurs on the main page of the US site 

Repro frequency: 100%
See attached: video, logcat, https://www.youtube.com/watch?v=IUlRONsXG1w
(Reporter)

Comment 1

4 years ago
This issue also reproduces on the Flame 2.1 (273mb), Buri 2.1, and the Flame 1.4(273mb). The browser crash/oom

Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140717040202
Gaia: Unknown
Gecko: a74600665875
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140717040202
Gaia: Unknown
Gecko: a74600665875
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 1.4(273MB)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140717063007
Gaia: e0a732cf172d125eadfad59f0faf8f73b62012b8
Gecko: 074223c547af
Version: 30.0 (1.4) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


__________________________________________________________________________________________________________________________

This issue does not reproduce on the Flame 2.0(512mb), Buri 2.0, Buri 1.4 and the Buri 1.3. the browser crash/OOM occurs does not occur 


Flame 2.0(512mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140717000201
Gaia: aa4f795b81c6147d67c4f06009e166debcf8856e
Gecko: 0ec0b9ac39f0
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140717000201
Gaia: aa4f795b81c6147d67c4f06009e166debcf8856e
Gecko: 0ec0b9ac39f0
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140717000201
Gaia: e0a732cf172d125eadfad59f0faf8f73b62012b8
Gecko: a429f0b6206d
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.3

Environmental Variables:
Device: Buri 1.3
Build ID: 20140717024001
Gaia: 23f55be856cef53c6604a6fe4aeb09061afbc897
Gecko: b9087513a198
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
Component: Gaia::Browser → Performance

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I cannot reproduce this on a 319mb flame running build id: 20140721000201.

Flagging for qawanted to retest on 319mb flame configuration.  If this doesn't repro on a 319mb flame, then this bug should be closed, won't fix.
Keywords: qawanted
Bug repros in Flame 2.1 and Flame 2.0

Flame 2.1 (319 MB)
Build ID: 20140730040205
Gaia: 25e998814ba89f30fe44cd2fdfbb44d160a04641
Gecko: 55c4d770f88b
Platform Version: 34.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0 (319 MB)
Build ID: 20140730000206
Gaia: 2e85678de2c8e13e585288d4cec7d6673cee17ee
Gecko: 6e37ecf873da
Platform Version: 32.0
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Actual result:  After zooming in all the way, that user will see an OOM after a few seconds of scrolling around the site.
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: ckreinbring
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(jmitchell)

Updated

4 years ago
Keywords: perf
Priority: -- → P3
Whiteboard: [273MB-Flame-Support] [2.0-exploratory] → [273MB-Flame-Support], [2.0-exploratory][c=memory p= s= u=]

Updated

3 years ago
tracking-b2g: --- → -

Comment 4

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.