Closed Bug 1040445 Opened 6 years ago Closed 4 years ago

Inserting newline in contenteditable div does not advance cursor

Categories

(Firefox for Android :: Keyboards and IME, defect)

30 Branch
x86_64
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jhchen7, Unassigned)

References

()

Details

Attachments

(1 file)

Attached file about-support.pdf
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

1. Visit http://jsfiddle.net/jhchen/puz5w/1/
2. Put the cursor at the end of a line
3. Hit enter


Actual results:

A newline will be inserted but the cursor will stay put.


Expected results:

A newline should have been entered and the cursor advanced onto the newline.

Attached is the pdf output of my about:support page. I am also running Android 4.4.4. This does not occur in mobile Chrome. This bug is also filed: https://support.mozilla.org/en-US/questions/1010816.
OS: Mac OS X → Android
Hardware: x86 → x86_64
I think this a dupe of bug 960449, but I only saw that when using bullets in a contenteditable. CC'ing Jim.
Status: UNCONFIRMED → NEW
Component: General → Keyboards and IME
Ever confirmed: true
I tried this:

data:text/html,<div contentEditable="true"><div>hello</div><div>world</div></div>

In Firefox beta (31) and could not reproduce issues - enter either at the end of the first or second world worked fine, and I could type on the next line. But 

data:text/html,<div contentEditable="true"><p>hello</p><p>world</p></div>

reproduces. I agree it's likely a dup of 960449.
(To be precise, what I see is that the cursor does advance, but when you start typing it jumps back to the end of the previous line)
Hello guys,
I'm still able to reproduce this bug on nexus tablet with Firefox 43.0. Are there any plans for fixing this issue in the near future?
One thing which was not mentioned here: when contenteditable div is empty, enter works fine even after typing some text, refocusing element, etc.
This is working for me now on Android 6.0.1 on Firefox 46 on the same Nexus tablet I originally tested with.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.