Status

()

Core
XSLT
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: sicking, Assigned: sicking)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

patch that implements lre stylesheets are coming up...
just to beat Pike to it... Some of this code is sub-optimal until ns-doom has 
landed
Status: NEW → ASSIGNED
Depends on: 76070
*** Bug 104789 has been marked as a duplicate of this bug. ***
Comment on attachment 52905 [details] [diff] [review]
here goes...

Rename processTopLevel (to processStylesheet or something better), move "stylesheet" and "transform" into Names.*. With those changes, r=peterv.
Attachment #52905 - Flags: review+
Attachment #52905 - Attachment is obsolete: true
Comment on attachment 53581 [details] [diff] [review]
addresses comments from peterv

rs=brendan@mozilla.org

Code looks ok (prevailing style suppresses out of memory errors, not sure that
matters in practice).

The Map and NamedMap hash tables will perform poorly under load.  Use xpcom/ds/pldhash.h as
their implementation basis instead.
/be
Attachment #53581 - Flags: superreview+
checked in

Thanks for reviews!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
works fine. verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.