YouTube HTML5 video stops playback and buffers forever when moving seek-bar back or forward if set media.mediasource.enabled = true

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

(Blocks: 1 bug, {reproducible})

Trunk
reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Steps To Reproduce:
1. Open http://www.youtube.com/watch?v=eYDjV7ajuMo
2. Wait buffering
3. Moving seek-bar back or forward

Actual Results:
Youtube HTML5 video stops playback.
Throbber is spinning.

Expected Results:
Video should continue playback
Did you seek to a position beyond the buffer range? Or did you seek back-and-forth after completely buffered?
(Reporter)

Comment 2

4 years ago
(In reply to JW Wang [:jwwang] from comment #1)
> Did you seek to a position beyond the buffer range? 
Yes

> did you seek back-and-forth after completely buffered?
Regardless of progress of buffering
(Reporter)

Updated

4 years ago
See Also: → bug 1040563
(Reporter)

Comment 3

4 years ago
Err
> Did you seek to a position beyond the buffer range? 
No.
Seeking within buffered range.
(Reporter)

Comment 4

4 years ago
Oops, I forgot to set media.mediasource.enabled = true.
The prefs causes the problem.
(Reporter)

Updated

4 years ago
Summary: Youtube HTML5 video stops playback when moving seek-bar back or forward → Youtube HTML5 video stops playback when moving seek-bar back or forward if set media.mediasource.enabled = true.
I see these YouTube buffering problems on OS X using Nightly 34. With media.mediasource.enabled = true, the video buffers forever when I try to skip ahead. YouTube's "Stats for nerds" reports the video is using VP9 with DASH. With media.mediasource.enabled = false, video playback skips ahead as expected and "Stats for nerds" reports the video is using VP8 without DASH.
Blocks: 778617
status-firefox34: --- → affected
Keywords: reproducible
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Youtube HTML5 video stops playback when moving seek-bar back or forward if set media.mediasource.enabled = true. → YouTube HTML5 video stops playback and buffers forever when moving seek-bar back or forward if set media.mediasource.enabled = true

Comment 6

3 years ago
With nightly 34a1 (2014-08-15)and media.mediasource.enabled = true
"Stats for nerds" reports the video is using VP9 with DASH.

If I skip back or forward in the buffered range, the video correctly appears immediately. 
So I don't see this bug.

However one time in two the sound doesn't work anymore. Then if I skip back or forward in the buffered range one or two time the sound works again.

Comment 7

3 years ago
i have this issue present with media.mediasource.enabled = true
VP9 and DASH. Fedora Linux 20. Latest Nightly 34.0a1 (2014-08-15).
Video - https://www.youtube.com/watch?v=cu_usjjvg-o

The video can seek back and play in the buffered range. 
But the video stops playback once it reaches the unbuffered range or it shows up some frame in the video after some time of loading/buffering

Plus video fails to play from a specific point on the seek bar if the video is unbuffered.
Surprisingly it shows the end of the video playback screen on YouTube if played from a random point of the seek bar.
Blocks: 1056440

Updated

3 years ago
Duplicate of this bug: 1054783

Comment 9

3 years ago
This is effectively a duplicate of the meta seeking bug 1056440. The following patches on mozilla-central fix seeking issues described here and we can close when they are landed/resolved.

bug 1061007 - is in inbound
bug 1059058 attachment 8481052 [details] [diff] [review]
R bug 1062020 - under review
R bug 1062018 - under review
bug 1061400/1059058 attachment 8481053 [details] [diff] [review]
bug 1059058 attachment 8481092 [details] [diff] [review]
bug 1062023 - complete and will be landed but has dependencies above

Updated

3 years ago

Updated

3 years ago
Assignee: nobody → cajbir.bugzilla
Status: NEW → ASSIGNED
Everything in comment 9 has landed, so resolving as fixed.  Please file a new bug for any seeking issues and make it block bug 1056440.
Assignee: cajbir.bugzilla → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1054782
status-firefox34: affected → ---
You need to log in before you can comment on or make changes to this bug.