Umlauts and accents are rendered next to the char, not as a part of the char - Adelle font

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Iurii Kudriavtsev, Unassigned)

Tracking

({regression, testcase})

30 Branch
x86
Mac OS X
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox31 affected, firefox32 ?, firefox33 fixed)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Umlauts and accents are rendered next to the character and not as a part of the character when using the Adelle font, e.g.:

"so¨me"

It happens because the string has unicode-escaped characters:

"so\u0308me"

As you can see, it has the char "o" and then the umlaut char - "\u0308".

The issue happens on Firefox Mac OS with Adelle font, that we use. I tried with Chrome Mac OS with Adelle or Firefox Mac OS with different font - the "ö" is rendered properly.

The Adelle font is actually able to render umlauts - if one tries with "ö", which is an html entity for "ö", then it's rendered properly.

So, I think, this is just because of the way, the char is encoded - the "o" char itself, then the umlaut char. I've tried also "söme" or "so¨me".
The issue was still there.
(Reporter)

Updated

4 years ago
Keywords: regression

Comment 1

4 years ago
Trying this out by copy-pasting: "söme" into the third tab of: https://typekit.com/fonts/adelle-web

reproduces the issue, but only on 31 (released Real Soon Now), not on 33 nightly... not sure where this was fixed. If you found a regression window with mozregression ( http://mozilla.github.io/mozregression/ ) then we could look at uplifting to 32/31 ESR if possible, depending on the patch that fixed this...

(I *think* mozregression supports looking for things which have been fixed instead of things that have been broken, assuming you pass it a --good date that's more recent than the --bad date)
status-firefox31: --- → affected
status-firefox32: --- → ?
status-firefox33: --- → fixed
Flags: needinfo?(iurii.kudriavtsev)
Keywords: testcase

Comment 2

4 years ago
Firefox 25.0.1-30.0 are also affected.

Comment 3

3 years ago
Per comment #1, this should be fixed for a while now, so marking WFM. Please reopen if you can still reproduce on a more recent Firefox build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(iurii.kudriavtsev)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.