Error running robocop tests locally

RESOLVED DUPLICATE of bug 1026710

Status

Testing
General
RESOLVED DUPLICATE of bug 1026710
4 years ago
4 years ago

People

(Reporter: wesj, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
It looks like bug 1026710 moved things over to use a lot of multiprocess stuff, but the proc.output data we're using isn't the right form for whats needed here.

input commmand:
TEST_PATH=testClearPrivateData MOZ_HOST_BIN=../firefox/dist/bin/ make -C ../fxteam-android/ 

ouput:
mochitest-robotiummake: Entering directory `/home/wesj/src/fxteam-android'
Traceback (most recent call last):
  File "_tests/testing/mochitest/runtestsremote.py", line 767, in <module>
    main()
  File "_tests/testing/mochitest/runtestsremote.py", line 572, in main
    dm = droid.DroidADB(deviceRoot=options.remoteTestRoot)
  File "/home/wesj/src/fxteam-android/_tests/testing/mochitest/devicemanagerADB.py", line 63, in __init__
    self.connect()
  File "/home/wesj/src/fxteam-android/_tests/testing/mochitest/devicemanagerADB.py", line 78, in connect
    self._checkForRoot()
  File "/home/wesj/src/fxteam-android/_tests/testing/mochitest/devicemanagerADB.py", line 642, in _checkForRoot
    if data.find('uid=0(root)') >= 0:
AttributeError: 'list' object has no attribute 'find'
I am having trouble reproducing but I think I see the trouble.

If you change http://hg.mozilla.org/mozilla-central/annotate/330ba968ed61/testing/mozbase/mozdevice/mozdevice/devicemanagerADB.py#l641:

data = proc.output

to:

data = proc.output[0]

does that work?
(Reporter)

Comment 2

4 years ago
Created attachment 8458805 [details] [diff] [review]
Patch
Attachment #8458805 - Flags: review?(wlachance)
Comment on attachment 8458805 [details] [diff] [review]
Patch

Review of attachment 8458805 [details] [diff] [review]:
-----------------------------------------------------------------

This is the right solution, but it looks like there are other things that need updating. Applying a patch.
Attachment #8458805 - Flags: review?(wlachance)
Let's fix this problem in bug 1026710, since that's the root cause and we haven't closed it yet.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1026710
You need to log in before you can comment on or make changes to this bug.