Hitting o+other key produces strange characters

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: hume, Assigned: masaki.katakai)

Tracking

({intl})

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
A strange little thing I've come across:

When typing into a textfield, if I type too fast, and hit 'o' and another 
character about simultaneously, I end up with a strange variation of the
second character.

For example, hitting 'o' and 'r' results in 'o®'.  's§' = o+s, 'o©' = o + c.

This bug has been in Mozilla for at least a few weeks, I just hadn't noticed
how to produce it reliably.

I'm currently using a custom build fr®m (see?) CVS pulled around 18:00 ADT
on 2001/10/10 (01/10/10)

Comment 1

17 years ago
Doesn't happen on WinNT 2001100708-trunk. Something in your window manager?
How many layers of software do keystrokes go through to get to the textarea?
(Reporter)

Comment 2

17 years ago
I haven't been able to reproduce it under Windows, and my FreeBSD box is
disabled at the moment s§ I can't test it there.

I use IceWM as my window manager.  I can't cause the problem to occur
in a non-Mozilla window, including Netscape 4.

I was hoping another Solaris user could give this a try, preferably under
a loaded c©ndition, since my SPARC is compatatively slow (75MHz SS20)

(Apparently t+h is another way of getting odd characters, like 'tþ'...)

Comment 3

17 years ago
trying to get some feedback...
Assignee: asa → yokoyama
Component: Browser-General → Internationalization
QA Contact: doronr → andreasb

Comment 4

17 years ago
I can't get this behavior to happen under Solaris 7 with build 2001101122.  I'm
using Windowmaker as my window manager. 

Comment 5

17 years ago
Switching QA contact to katakai@japan.sun.com for now.
Keywords: intl
QA Contact: andreasb → katakai

Comment 6

17 years ago
Solaris problem. Give to katakai@japan.sun.com
Assignee: yokoyama → katakai
(Assignee)

Comment 7

17 years ago
Brandon,

I'm Solaris user.

Can you tell me more detail about your environment?
e.g. version of SunOS, your locale, your kbd type.

Thanks.
(Reporter)

Comment 8

17 years ago
I'm running Solaris 8 (Generic_108528-05) on a 75 MHz SS20.  C locale, with
a type 5 (PC type) keyboard.

I've tried running Mozilla off a nearby E250 running Solaris 7, displayed
onto my SS20, and was not able to reproduce the problem.

I haven't yet had a chance to try running Mozilla under a different window
manager on the SS20.  I'm curious as to whether it might be a relative CPU
speed issue.
(Assignee)

Comment 9

17 years ago
Thanks for the info. OK, I'll try on the slow machine.

As you know, compose + o + c should input just '©' not 'c©'.

Comment 10

17 years ago
Brandon, please can you check to see whether this bug is still present in a
recent build (Moz1-RC1 or a new nightly build). If this bug does not occur
please can you
resolve it worksforme.
(Reporter)

Comment 11

17 years ago
I'm no longer able to reproduce this problem.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
verified
Status: RESOLVED → VERIFIED

Comment 13

17 years ago
I can reproduce this problem using Mozilla/5.0 (X11; U; SunOS sun4u; en-US;
rv:1.0rc1) Gecko/20020418 on Solaris 8.

In addition to the examples mentioned, like o+r = "r®", I also experienced that
pressing space and some other key at the same time doubles the key, e.g.
<space>+, = ",,".

This is the only version of Mozilla I have been running on this platform. Before
that I used Netscape 6.2.2 which did have this problem.

There doesn't seem to be made new binaries for Solaris since RC1, so I am not
able to see if the problem has been fixed since then.

Comment 14

17 years ago
BTW I use Common Desktop Environment; C locale; keyboard is type 6 USB with
Danish characters (фье).

$ uname -a
SunOS sun1 5.8 Generic_111850-02 sun4u sparc SUNW,Sun-Blade-1000

Comment 15

17 years ago
Re-opening based on comments.

Christian, RC2 isn't available yet from mozilla.org for Sparc, but it should be
soon.  So instead why don't you try the latest Sparc nightly build: 
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-sparc-sun-solaris2.6.tar.gz
- I'm guessing the problem won't have been fixed yet.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 16

17 years ago
Except that the 'latest' sparc nightly is dated ... 18 April, i.e., around the
time of RC1.

Comment 17

17 years ago
> So instead why don't you try the latest Sparc nightly build:
I didn't know that was a possibility.


> I'm guessing the problem won't have been fixed yet.
Well, I cannot reproduce it using Mozilla/5.0 (X11; U; SunOS sun4u; en-US;
rv:1.0.0+) Gecko/20020514.


The User-Agent string is the same in the two versions (except for the date). Is
there in fact a difference between mozilla-sparc-sun-solaris2.6.tar.gz and
mozilla-sparc-sun-solaris-7_8_9.tar.gz? (I don't know much about Sun systems)

I'll try to download the Solaris 8 version, when it becomes available, to see if
I can reproduce it using that.

Comment 18

17 years ago
I would recommend not usin the 7_8_9 Sparc nightly build which is only updated
sporadically and has never worked for me on Solaris 7 (bug 136144).  Use the
Solaris 2.6 build that I linked to.  It should work for any Solaris 2.6 and above.

The differences between the 7_8_9 build and the 2.6 build have to do with the
machine used to compile it and possibly different options used to compile it. 
Because of forward compatibility on Solaris, builds compiled on 2.6 machines
should run fine on later versions on Solaris.

I'll go ahead and leave this bug open until you have had a chance to test on
RC2. Sporadic bugs like this can be a pain to track down.

Comment 19

17 years ago
Did you have a chance to test a more recent version?

pi

Comment 20

17 years ago
I have not been able to find a newer Solaris 7-8-9 build. The latest nightly
build for Solaris 7-8-9 in
http://komodo.mozilla.org/pub/mozilla/nightly/latest-trunk/ still seems to be
build 20020514 (though the file date in the listing says May 30).

Since then I have been using Solaris 2.6 versions, including the 1.0 release. I
have not experienced the problem with these.

Comment 21

17 years ago
Since it worked for the other versions I mark this bug WFM. Please reopen if you
can again produce this with a newer build on 7-8-9.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.