Closed Bug 1040831 Opened 8 years ago Closed 8 years ago

Daily 33.0a1 gives "Couldn't load XPCOM" error and startup fails since updating this morning

Categories

(Thunderbird :: Installer, defect)

33 Branch
x86
All
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 33.0

People

(Reporter: joshua.and.delaine, Assigned: Paenglab)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:30.0) Gecko/20100101 Firefox/30.0 Waterfox/30.0 (Beta/Release)
Build ID: 20140708101823

Steps to reproduce:

Updated to the latest build of daily via updater


Actual results:

When the updater restarted the application, an error message popped up stating "Couldn't load XPCOM" and the application did not launch. Attempted to manually reinstall and got same error. Attempted copying files from the appropriate zip file and still got same error.


Expected results:

The application should have just launched and let me check my e-mail.
Severity: normal → blocker
Keywords: 64bit
Hardware: x86 → x86_64
Note, I have also tried uninstalling and reinstalling Daily 33.0a1 from installer and still get same error, though I did not restart after uninstall. I will test that next.
Confirmed also on Windows 7 with the 32-bit nightly build. The error dialog immediately shows up on start. Also happens when trying to start in safe mode.
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Keywords: 64bitdogfood
Summary: Daily 33.0a1 64-bit gives unable to load XPCOM error since updating this morning → Daily 33.0a1 gives "Couldn't load XPCOM" error and startup fails since updating this morning
I think that's right for platform. I don't see a windows all choice
OS: Windows 8.1 → All
Hardware: x86_64 → x86
As detailed in Bug 1040939, this is fallout from bug 985252
Attached patch fixXPCOM.patch (obsolete) — Splinter Review
This is a copy of the patch from bug 1040939. This works for me with a buils I zipped through mach package. Without patch it fails.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8458965 - Flags: review?(Pidgeot18)
A whitespace slipped in.
Attachment #8458965 - Attachment is obsolete: true
Attachment #8458965 - Flags: review?(Pidgeot18)
Attachment #8458970 - Flags: review?(Pidgeot18)
Attachment #8458970 - Flags: review?(Pidgeot18) → review+
Component: General → Installer
a=bustage fix per jcranmer
Keywords: dogfoodcheckin-needed
Comment on attachment 8458970 [details] [diff] [review]
fixXPCOM.patch r=jcranmer a=bustage fix [check-in comment 8]

Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/dd587f8d4d97
Attachment #8458970 - Attachment description: fixXPCOM.patch → fixXPCOM.patch r=jcranmer a=bustage fix [check-in comment 8]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 33.0
Keywords: regression
Fixed? Just tested with win32 build from Fr. 18.07.2014 at 11:15:00 [1] - still XPCOM error. Will try again tomorrow.

[1] ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/
(In reply to Peter Lairo from comment #9)
> Fixed? Just tested with win32 build from Fr. 18.07.2014 at 11:15:00 [1] -
> still XPCOM error. Will try again tomorrow.
> 
> [1] ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/

uhmm, at this precise point in time, those builds are still from *yesterday* and of course don't have the patch.
You're right. I thought the bug was resolved FIXED *today* at 5:30 (my bad) (and the download build was from 11:15). I'll wait until the next build appears...
Times on the FTP server are in UTC. The 19-Jul-2014 11:11 Windows build has the patch.
verified fixed in nightly 20140719030210
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.