[B2G][Browser] When the user tap on 'Map' or 'Edit Route' in MapQuest, the buttons does not function

RESOLVED DUPLICATE of bug 1001491

Status

Tech Evangelism
Mobile
RESOLVED DUPLICATE of bug 1001491
4 years ago
4 years ago

People

(Reporter: Petes, Unassigned, Mentored)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support] [2.0-exploratory] [js] [country-all], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8458865 [details]
mp.txt

Description:
When the user tap on 'Map' or 'Edit Route' in MapQuest, the buttons does not function 

Setup Steps:
1) Flame device is set to 273mb

Repro Steps:
1) Update a Flame device to BuildID: 20140718000232
2) Go to Browser
3) Go m.mapquest.com
4) Insert an address > tap go  
5) Tap either 'Map' or 'Edit Route'


Actual:
The buttons for 'Map' and 'Edit Route' does not function 

Expected:
The buttons for 'Map' and 'Edit Route' function

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140718000232
Gaia: 34c24749e78496ac1317f4ddb573281c0ef2995e
Gecko: 76309f978531
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0



Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8458867 [details]
2014-07-18-10-48-10.png
(Reporter)

Comment 2

4 years ago
This issue also reproduces on the Flame 2.1 (273mb), Buri 2.1, Flame 2.0(512mb), Buri 2.0, Flame 1.4(273mb), and the Buri 1.4. The buttons for 'Map' and 'Edit Route' does not function.  


Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master 
Build ID: 20140718040202
Gaia: Unknown
Gecko: e6e8c93a1b6e
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.1

v2.1 Environmental Variables:
Device: Buri Master
BuildID: 20140718040202
Gaia:
Gecko: e6e8c93a1b6e
Version: 33.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.0(512mb)

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140718000232
Gaia: 34c24749e78496ac1317f4ddb573281c0ef2995e
Gecko: 76309f978531
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0 
Build ID: 20140718000232
Gaia: 34c24749e78496ac1317f4ddb573281c0ef2995e
Gecko: 76309f978531
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4(273MB)

v1.4 Environmental Variables:
Device: Flame v1.4 
BuildID: 20140718000231
Gaia: e0a732cf172d125eadfad59f0faf8f73b62012b8
Gecko: 074223c547af
Version: 30.0
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4

v1.4 Environmental Variables:
Device: Buri v1.4 
BuildID: 20140718000231
Gaia: e0a732cf172d125eadfad59f0faf8f73b62012b8
Gecko: 074223c547af
Version: 30.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

_______________________________________________________________________________________________________________________

The issue does not reproduce on the Buri 1.3 because the address will not load to the List View.

Buri 1.3

Environmental Variables:
Device: Buri 1.3
Build ID: 20140717024001
Gaia: 23f55be856cef53c6604a6fe4aeb09061afbc897
Gecko: b9087513a198
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v1.3: unaffected → ---
Flags: needinfo?(ktucker)

Comment 3

4 years ago
Hallvord, an idea about what is happening?


So after entering the address, the list view of the directions is displayed with a top menu containing:

[Map] [List View] [Edit Route]

Indeed the buttons get selected (there is a dotted outline around them), but are not active.

When faking the user agent to be Firefox oS on Firefox Desktop, we can reproduce the issue.


The map button is an empty link so not very accessible and it seems not populated at all with the link.

<a data-wrapperels="span" data-iconshadow="true" data-shadow="true" data-corners="true" class="ui-btn-left ui-btn ui-shadow ui-btn-corner-all ui-btn-up-t" href="#" id="narrativeBack" data-direction="reverse" data-role="button" data-theme="t"><span class="ui-btn-inner"><span class="ui-btn-text">Map</span></span></a>


The site has also a piece of code which will fail for iPodTouch Safari.
    <script>
        if ($.browser.safari && navigator.userAgent.indexOf("iPhone")>-1) {
            $("body").addClass("mobile-safari");
        }
    </script>
Mentor: kdubost
Flags: needinfo?(hsteen)
Whiteboard: [273MB-Flame-Support] [2.0-exploratory] → [273MB-Flame-Support] [2.0-exploratory] [js] [country-all]

Updated

4 years ago
See Also: → bug 1040886
Mentor: kdubost
See Also: → bug 1001491
Mentor: kdubost
Flags: needinfo?(hsteen)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I think this is a dup of bug 1001491 and I will try to get it analysed soon
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1001491
You need to log in before you can comment on or make changes to this bug.