Shutdown crash when devtools mochitests are run in Mulet

RESOLVED WONTFIX

Status

Firefox OS
Runtime
P2
normal
RESOLVED WONTFIX
4 years ago
11 months ago

People

(Reporter: jgriffin, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Reporter)

Description

4 years ago
There's a shutdown crash after successfully running the devtools mochitests on Mulet.

Log: https://tbpl.mozilla.org/php/getParsedLog.php?id=43983607&tree=Fig&full=1#error1

19:06:08     INFO -  *** End BrowserChrome Test Results ***
19:06:08     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
19:06:08     INFO -  JavaScript strict warning: chrome://global/content/bindings/textbox.xml, line 176: reference to undefined property this.inputField.foo
19:06:08     INFO -  JavaScript strict warning: chrome://global/content/bindings/textbox.xml, line 176: reference to undefined property this.inputField.foo
19:06:08     INFO -  JavaScript strict warning: chrome://global/content/bindings/textbox.xml, line 176: reference to undefined property this.inputField.foo
19:06:08     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
19:06:08     INFO -  ###!!! [Child][DispatchAsyncMessage] Error: Route error: message sent to unknown actor ID
19:06:09     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
19:06:09     INFO -  1405562769245	Browser.Experiments.Experiments	TRACE	Experiments #0::uninit: started
19:06:09     INFO -  1405562769251	Browser.Experiments.Experiments	TRACE	Experiments #0::uninit: finished with _loadTask
19:06:09     INFO -  1405562769252	Browser.Experiments.Experiments	TRACE	Experiments #0::uninit: no previous shutdown
19:06:09     INFO -  1405562769253	Browser.Experiments.Experiments	TRACE	Experiments #0::Unregistering instance with Addon Manager.
19:06:09     INFO -  1405562769257	Browser.Experiments.Experiments	TRACE	PreviousExperimentProvider #0::shutdown()
19:06:09     INFO -  1405562769259	Browser.Experiments.Experiments	INFO	Experiments #0::Completed uninitialization.
19:06:19     INFO -  WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"AddonManager: shutting down providers","state":"(none)","filename":"resource://gre/modules/AddonManager.jsm","lineNumber":741,"stack":["resource://gre/modules/AddonManager.jsm:AMI_startup:741","resource://gre/modules/AddonManager.jsm:AMP_startup:2319","jar:file:///builds/slave/test/build/application/firefox/omni.ja!/components/addonManager.js:AMC_observe:55","null:null:0"]}] Barrier: profile-before-change
19:07:10     INFO -  FATAL ERROR: AsyncShutdown timeout in profile-before-change Conditions: [{"name":"AddonManager: shutting down providers","state":"(none)","filename":"resource://gre/modules/AddonManager.jsm","lineNumber":741,"stack":["resource://gre/modules/AddonManager.jsm:AMI_startup:741","resource://gre/modules/AddonManager.jsm:AMP_startup:2319","jar:file:///builds/slave/test/build/application/firefox/omni.ja!/components/addonManager.js:AMC_observe:55","null:null:0"]}] At least one completion condition failed to complete within a reasonable amount of time. Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources.
19:07:10     INFO -  [Parent 1800] ###!!! ABORT: file resource://gre/modules/AddonManager.jsm, line 741
19:07:10     INFO -  [Parent 1800] ###!!! ABORT: file resource://gre/modules/AddonManager.jsm, line 741
19:07:11     INFO -  TEST-INFO | Main app process: killed by SIGSEGV
19:07:11  WARNING -  TEST-UNEXPECTED-FAIL | Shutdown | application terminated with exit code 11
19:07:11     INFO -  INFO | runtests.py | Application ran for: 1:51:06.832471
19:07:11     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpejgdc2pidlog
19:07:11     INFO -  ==> process 1800 launched child process 1844
19:07:11     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 1844
19:07:11     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fig-linux64-mulet/1405551404/firefox-33.0a1.en-US.linux-x86_64.crashreporter-symbols.zip
19:07:21  WARNING -  PROCESS-CRASH | Shutdown | application crashed [@ mozalloc_abort(char const*)]
19:07:21     INFO -  Crash dump filename: /tmp/tmpvVwm27.mozrunner/minidumps/5661b2ea-6877-28f4-4e481634-5d7d82d3.dmp
19:07:21     INFO -  Operating system: Linux
19:07:21     INFO -                    0.0.0 Linux 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
19:07:21     INFO -  CPU: amd64
19:07:21     INFO -       family 6 model 45 stepping 7
19:07:21     INFO -       1 CPU
19:07:21     INFO -  Crash reason:  SIGSEGV
19:07:21     INFO -  Crash address: 0x0
19:07:21     INFO -  Thread 0 (crashed)
19:07:21     INFO -   0  libmozalloc.so!mozalloc_abort(char const*) [mozalloc_abort.cpp:c568ae83afef : 30 + 0x0]
19:07:21     INFO -      rbx = 0x00007f0a8405e828   r12 = 0x00007fff2ea31c54
19:07:21     INFO -      r13 = 0x00007f0a8405e828   r14 = 0x0000000000000000
19:07:21     INFO -      r15 = 0x0000000000000000   rip = 0x00007f0a826ba407
19:07:21     INFO -      rsp = 0x00007fff2ea31bf0   rbp = 0x00007fff2ea31c00
19:07:21     INFO -      Found by: given as instruction pointer in context
19:07:21     INFO -   1  libxul.so!NS_DebugBreak [nsDebugImpl.cpp:c568ae83afef : 472 + 0xb]
19:07:21     INFO -      rbx = 0x0000000000000003   r12 = 0x00007fff2ea31c54
19:07:21     INFO -      r13 = 0x00007f0a8405e828   r14 = 0x0000000000000000
19:07:21     INFO -      r15 = 0x0000000000000000   rip = 0x00007f0a7ed0df1b
19:07:21     INFO -      rsp = 0x00007fff2ea31c10   rbp = 0x00007fff2ea32070
19:07:21     INFO -      Found by: call frame info
...etc
Looks like I'm having the same crash with bug 1208083. 100% reproducible, including on gaia-try.

The gdb stack trace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f624d1ff700 (LWP 21017)]
0x000000000040a4e5 in mozalloc_abort(char const*) ()
(gdb) where
#0  0x000000000040a4e5 in mozalloc_abort(char const*) ()
(gdb)
Blocks: 1208083
[Blocking Requested - why for this release]:
Because it prevent from increasing test coverage for the new Music app (see comment 1) that that's a 2.5 feature.
blocking-b2g: --- → 2.5?
STR:
- Pull the branch in PR attachment 8669708 [details] [review]
- |TEST_FILES=./apps/music/test/marionette/search_test.js make test-integration|
- "Search context tests" will fail, with "AssertionError: Error: Connection reset by peer!"

Expected
- Pass OR a "no crash" test failure (I haven't been able to ever run that test on this version of the app)
Whats the whole stack here? It cuts off when its getting interesting.
Yes that's the whole stack. 

Also
(gdb) thread apply all bt
Cannot find new threads: generic error
(gdb) 

This is on the "plugin-container" process.
Blocking for 2.5 with a P2 priority. 

Alexender  can you see this or assign it to a right person?
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(lissyx+mozillians)
Priority: -- → P2
(In reply to Hubert Figuiere [:hub] from comment #3)
> STR:
> - Pull the branch in PR attachment 8669708 [details] [review]
> - |TEST_FILES=./apps/music/test/marionette/search_test.js make
> test-integration|
> - "Search context tests" will fail, with "AssertionError: Error: Connection
> reset by peer!"
> 
> Expected
> - Pass OR a "no crash" test failure (I haven't been able to ever run that
> test on this version of the app)

Can't you provide more logs ?
Flags: needinfo?(lissyx+mozillians) → needinfo?(hub)
Assignee: nobody → lissyx+mozillians
Integration tests failing to run at all for me ...
I'm sorry, it's late for me, I'm already 100% on another nasty 2.5+ and integration tests do not want to run locally. I'm PTO tomorrow, so I guess you should find someone else.
Assignee: lissyx+mozillians → nobody
Flags: needinfo?(mpotharaju)

Updated

2 years ago
No longer blocks: 1208083
Good news and bad news: rebased the PR it no longer crashes (same runtime). Bug still exist, just no longer triggered.
Flags: needinfo?(hub)
[Tracking Requested - why for this release]:

Putting it as part of backlog and needs to be addressed soon after branching OR once P1s are complete.
blocking-b2g: 2.5+ → ---
tracking-b2g: --- → backlog
Clearing NI
Flags: needinfo?(mpotharaju)
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.