This shouldn't kill xpcshell.

VERIFIED DUPLICATE of bug 3649

Status

()

Core
XPConnect
--
major
VERIFIED DUPLICATE of bug 3649
16 years ago
16 years ago

People

(Reporter: timeless, Assigned: David Bradley)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
freebsd cvs build
./run-mozilla.sh ./xpcshell
js> var a=''; var b="<a href='data:text/html,"; var c="'>test</a>";
js> for (i=0;i<(2<<16);i++) a+="&#x"+i.toString(16)+";";
Killed[out of swap space]

w98
C:\WINDOWS\Desktop>cscript memory.js
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

done

C:\WINDOWS\Desktop>type memory.js
var a=''; var b="<a href='data:text/html,"; var c="'>test</a>";
for (i=0;i<(2<<16);i++) a+="&#x"+i.toString(16)+";";
WScript.echo("done");
C:\WINDOWS\Desktop>

each of memory allocated, swapfile in use and swapfile sized dropped no more
than 25mb after cscript quit.

The url field here generated an out of memory error in my jsconsole after
sapping cpu and swap for a very long time (i think nearly an hour). Kudos for
not crashing, however i'd like us to be at least as good as cscript.

Comment 1

16 years ago
--> XPConnect; 

cc'ing jband
Assignee: rogerl → dbradley
Component: Javascript Engine → XPConnect

Comment 2

16 years ago
Created attachment 52963 [details]
Timeless' testcase

Comment 3

16 years ago
Is this XPConnect or JS Engine? I may have misassigned this.

cc'ing Brendan for his opinion on this -

Comment 4

16 years ago
Looks like a dup of bug 3649 to me. Too many temp strings not getting gc'd
because xpcshell (like js.c) does not install a branch callback to do a maybe gc.

*** This bug has been marked as a duplicate of 3649 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Marking Verified Duplicate -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.