Closed Bug 1041019 Opened 5 years ago Closed 4 years ago

For flex item with intrinsic aspect ratio, cross size is set based on "flex-basis" instead of on final main size

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 1030952

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(1 file)

Attached file testcase 1
STR:
 1. Load testcase.

EXPECTED RESULTS: Purple areas should be square (I think).

ACTUAL RESULTS: Top two ones are tall-and-skinny; bottom is short-and-fat.


In each case, there is a particular "flex-basis" value in play, but we end up at a different main-size (width) from that flex-basis. (because of shrinking in the first two cases, and growing in the last case)

Despite that shrinking/growing, we appear to be setting the flex item's height based on the flex-basis (instead of the final width), combined with the intrinsic aspect ratio.
Actually, this is effectively a dupe of bug 1030952 (see spec quote in bug 1030952 comment 8 in particular).
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030952
I verified that this bug's testcase renders as 3 squares now in latest Nightly 49.0a1 (2016-05-02) (which has the duplicate-target bug's fix).
 --> Verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.