Closed Bug 1041136 Opened 6 years ago Closed 6 years ago

Errors while setting proxy for libpurple based accounts and deleting profile

Categories

(Instantbird :: Other, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sawrubh, Unassigned)

References

Details

I was using this profile for testing and had SOCKS5 turned on. I turned off my computer, restarted next day and the SOCKS5 proxy setting is not there 'For libpurple-based accounts' network settings however the SOCKS5 proxy setting is still there in 'For everything else' proxy settings. Then I clicked on the settings button for 'For libpurple-based accounts' and I get this error in the error console: 

Timestamp: Saturday 19 July 2014 03:16:49  IST
Error: NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [purpleICoreService.getProxies]
Source File: chrome://instantbird/content/proxies.js
Line: 50

however the window opens but I'm not able to set the proxy settings in the 'Other' category. I then close the window and try to delete this profile and I get this error:

Timestamp: Saturday 19 July 2014 03:20:07  IST
Error: aJID.trim is not a function
Source File: resource:///modules/xmpp.jsm
Line: 1158

Timestamp: Saturday 19 July 2014 03:20:07  IST
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "aJID.trim is not a function" {file: "resource:///modules/xmpp.jsm" line: 1158}]'[JavaScript Error: "aJID.trim is not a function" {file: "resource:///modules/xmpp.jsm" line: 1158}]' when calling method: [prplIAccount::remove]
Source File: file:///home/sawrubh/Mozilla/comm-central/obj-x86_64-unknown-linux-gnu/mozilla/dist/bin/components/imAccounts.js
Line: 621

I have chat.prpl.forcePurple set to 'js-xmpp,...' instead of 'prpl-jabber' if that makes a difference.
Depends on: 1105889
The first error is now fixed, and I could not reproduce the second by creating and then deleting a JS-XMPP account, so maybe that was fixed too.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.