4 sites stored as Homepage do not come up at startup (due to "Sandboxie" application)

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: George Bourrie, Unassigned)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2; NP06; rv:11.0) like Gecko

Steps to reproduce:

After startup, open 4 windows with different websites.  In Tools, Options, General, click on Use Current Page: all 4 web addresses should be in the Home Page field.  Be sure that "When Firefox starts:" should have "Show my Home Page" selected.  Click on OK.


Actual results:

When Firefox was restarted, the 4 web addresses were still stored in the Home Page field but none of the windows opened.


Expected results:

4 windows should have opened with the 4 websites displayed.
This works for me with Firefox30 on Windows7. All 4 pages open on startup

Comment 2

4 years ago
Thanks for taking the time to report this!
Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems. It does not disable plugins which are add-ons.) See http://support.mozilla.com/en-US/kb/Safe+Mode 

And does this also happen with a new and empty profile? See http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles
Flags: needinfo?(gbourrie)
(Reporter)

Comment 3

4 years ago
Sorry it took so long to report back.  I tried a lot of things -- no improvement.  Eventually, I totally removed Firefox version 30 and replaced it with version 31 -- same result.  Finally found the culprit -- Sandboxie, a program that runs other programs in a sandbox.  In this case, the Firefox was the program in the sandbox -- to prevent malware from coming into the computer via the browser.  In Sanboxie's Control bos, I selected "Disable Forced Programs" for a sufficiently long time (1500 seconds) to stop Sandboxie from working temporarily. I then entered the 4 websites and stored them as my homepage.  I then shut down Firefox and restarted it -- the websites were remembered!  I restarted Sandboxie (unclicked "Disable Forced Programs") and everything was still okay.  Sandboxie must have been somehow confused and now was operating the way it was supposed to.
Flags: needinfo?(gbourrie)

Comment 4

4 years ago
Glad you found out the reason, and thanks for sharing it here!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Summary: 4 sites stored as Homepage do not come up at startup in vers. 30 → 4 sites stored as Homepage do not come up at startup (due to "Sandboxie" application)
You need to log in before you can comment on or make changes to this bug.