Closed Bug 1041383 Opened 6 years ago Closed 6 years ago

[User Story] Removing notifications with a leftward swipe

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(feature-b2g:2.1, tracking-b2g:backlog)

RESOLVED FIXED
2.1 S1 (1aug)
feature-b2g 2.1
tracking-b2g backlog

People

(Reporter: pdol, Assigned: cwiiis)

References

Details

(Keywords: feature, Whiteboard: [ucid:System242], [ft:systemsfe])

User Story

As a user, I want to be able to swipe notifications away to the left in addition to right to make them easier to dismiss.

Acceptance Criteria:
1. Swiping left on a notification in the utility tray removes the notification in the same way that swiping right does.

Attachments

(1 file)

No description provided.
I think Michael was going to work on this/had a prototype?
I was mistaken - taking.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
ok, this does a bit more than the bug says, but I think you'll agree it needed to be done :)

I expect this to break a few tests, but it's easier for me to wait for the try server than run them all locally - I'll fix them as they come in.
Attachment #8461650 - Flags: review?(mhenretty)
Comment on attachment 8461650 [details] [review]
Allow notifications to be dismissed with a leftward swipe

Awesome! This is so much nicer than it used to be. Code looks good too, I left a small comment on github about possibly getting rid of some old code, but r+.

One small issue I found is if a user starts swiping the notification toaster, and then we hit the toaster timeout while swiping, which makes the toaster disappear. It looks like the user swiped away the notification, but instead the notification stays in the tray. I think this is an edge case though.
Attachment #8461650 - Flags: review?(mhenretty) → review+
(In reply to Michael Henretty [:mhenretty] from comment #4)
> Comment on attachment 8461650 [details] [review]
> Allow notifications to be dismissed with a leftward swipe
> 
> Awesome! This is so much nicer than it used to be. Code looks good too, I
> left a small comment on github about possibly getting rid of some old code,
> but r+.
> 
> One small issue I found is if a user starts swiping the notification
> toaster, and then we hit the toaster timeout while swiping, which makes the
> toaster disappear. It looks like the user swiped away the notification, but
> instead the notification stays in the tray. I think this is an edge case
> though.

I'll remove the gesture detectors, thanks for the notes :)

I'm going to leave the toaster bits, I notice they miss any transitions entirely, so I think a separate bug about toaster transitions would be a better place to fix this (I'll file this).
Merged with master: https://github.com/mozilla-b2g/gaia/commit/58242f4d34493a412907663513d935c1ddf19fd5

Was hitting what appears to be an unrelated failure (bug 1043870) so took the risk.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 978726
Target Milestone: --- → 2.1 S1 (1aug)
Depends on: 1062321
Depends on: 1088224
No longer depends on: 1088224
Blocks: 1062321
No longer depends on: 1062321
No longer blocks: 1044406, 1062321
Depends on: 1044406, 1062321
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.