Closed Bug 1041471 Opened 5 years ago Closed 5 years ago

[Home Screen][v2.0] The home screen is froze there after scrolling it then tap the notification bar.

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
2.1 S1 (1aug)
blocking-b2g 2.0+
Tracking Status
firefox32 --- wontfix
firefox33 --- wontfix
firefox34 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- verified

People

(Reporter: whsu, Assigned: botond)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files, 1 obsolete file)

Attached video WP_20140721_003.mp4
* Description:
  The home screen is froze there after scrolling it then tap the notification bar.
  But, you can recovery it via home button.
  Attach the demo video: WP_20140721_003.mp4

* Reproduction steps:
  1. Use one finger to scroll homescreen to the bottom
  2. Use the other finger to tap notification bar

* Expected result:
  The home screen is resized and released.

* Actual result:
  The home screen is froze there

* Reproduction build: (v2.0 - Flame)
 - Gaia      8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
 - Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/c6f9f0396153
 - BuildID   20140720160208
 - Version   32.0a2
blocking-b2g: --- → 2.0?
blocking-b2g: 2.0? → 2.0+
Whiteboard: [systemsfe]
Seems related to overscroll to me, able to reproduce it on the first shot (video is helpful for STR).
Blocks: 998025
Component: Gaia::Homescreen → Panning and Zooming
Product: Firefox OS → Core
I suppose the home button fixes this by calling "scrollTo" on the homescreen. It's also possible to get an app stuck in this state, but sending it to the background and re-opening it will fix the stuck state.
The same happens in settings app for instance so I agree with Kevin
The home button does not work for me 

[JavaScript Error: "elt is undefined" {file: "chrome://global/content/BrowserElementPanning.js" line: 483}]

but sending settings to the background and re-opening it will fix the stuck state for apps

(In reply to Kevin Grandon :kgrandon from comment #2)
> I suppose the home button fixes this by calling "scrollTo" on the
> homescreen. It's also possible to get an app stuck in this state, but
> sending it to the background and re-opening it will fix the stuck state.
Well the home button works fine when you are in the middle or on the bottom but it does not work when you are on the top because in that case we don't call to scrollTo
Assignee: nobody → bugmail.mozilla
Target Milestone: --- → 2.1 S1 (1aug)
We seem to be running into a lot of cases where we get stuck in overscroll. I'm starting to think that this approach of ignoring touch input when in overscroll is pretty brittle in that sense. Maybe for future versions we should revisit this and see if there's a better way to deal with it.
Assignee: bugmail.mozilla → botond
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Whiteboard: [systemsfe]
Blocks: 1015336
Attached patch bug1041471.patch (obsolete) — Splinter Review
The homescreen's APZC receives a touch-end when the notification is tapped.

Currently APZC only calls SetState(NOTHING) on a touch-end. This patch changes it to call CancelAnimation(), which does additional cleanup, including clearing overscroll.
Attachment #8459761 - Flags: review?(bugmail.mozilla)
(In reply to Botond Ballo [:botond] from comment #7)
> The homescreen's APZC receives a touch-end when the notification is tapped.
> 
> Currently APZC only calls SetState(NOTHING) on a touch-end.

s/touch-end/touch-cancel/
Comment on attachment 8459761 [details] [diff] [review]
bug1041471.patch

Review of attachment 8459761 [details] [diff] [review]:
-----------------------------------------------------------------

Fix commit message s/end/cancel/
Attachment #8459761 - Flags: review?(bugmail.mozilla) → review+
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> (In reply to Botond Ballo [:botond] from comment #7)
> > The homescreen's APZC receives a touch-end when the notification is tapped.
> > 
> > Currently APZC only calls SetState(NOTHING) on a touch-end.
> 
> s/touch-end/touch-cancel/

Whoops, thanks for the correction!
Attached patch bug1041471.patchSplinter Review
Updated to fix commit message. Carrying r+.
Attachment #8459761 - Attachment is obsolete: true
Attachment #8459764 - Flags: review+
Try push that includes this patch: https://tbpl.mozilla.org/?tree=Try&rev=bde65e260011
Whiteboard: [systemsfe]
https://hg.mozilla.org/mozilla-central/rev/abe6b92d330b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Verified this patch on latest v2.0 build.
Thanks!

* Build information:
 - Gaia      2e85678de2c8e13e585288d4cec7d6673cee17ee
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/6e37ecf873da
 - BuildID   20140729160209
 - Version   32.0
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1050789
This issue has been verified successfully on Flame 2.1

See attachment: Verify_video.3gp
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0

The home screen does not respond when we scroll homescreen to the bottom on Flame 2.0,so we can't verify it.
Flame 2.0 versions:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/29222e215db8
Build-ID        20141203000201
Version         32.0
Attached video Verify_video.3gp
You need to log in before you can comment on or make changes to this bug.