Closed Bug 1041566 Opened 7 years ago Closed 7 years ago

Lightning 3.5 broken with 2014-07-21 update

Categories

(Calendar :: General, defect)

Lightning 3.5
x86_64
Linux
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bc, Assigned: Fallen)

Details

(Keywords: regression)

Attachments

(1 file)

After updating Thunderbird Daily 2014-07-21 and finding the Lightning 3.5a1 update applied, I can no longer open the Today Pane. The Error console shows

Error: classInfo.interfaces is undefined
Source File: resource://gre/modules/XPCOMUtils.jsm
Line: 136

Error: NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
Source File: resource://calendar/modules/calUtils.jsm
Line: 16
Version: unspecified → Lightning 3.5
Attached patch Fix - v1 β€” β€” Splinter Review
I haven't actually tested this, but I assume its because of these two typos. I hope it doesn't cause issues on Lightning 3.3, but given its been "working" before it should be fine on those branches.

Bob, can you test this patch, or do you need an xpi to give it a try?
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #8459682 - Flags: review?(matthew.mecca)
Comment on attachment 8459682 [details] [diff] [review]
Fix - v1

fixes the problem for me on Windows platform, r=ssitter
Attachment #8459682 - Flags: review?(matthew.mecca) → review+
 Philipp, I edited the files directly in my profile and the today pane works for me.
Comment on attachment 8459682 [details] [diff] [review]
Fix - v1

Approving for aurora and beta after the merge. Will set checkin-needed because the trees are only semi-open.
Attachment #8459682 - Flags: approval-calendar-beta+
Attachment #8459682 - Flags: approval-calendar-aurora+
I think the bustage - or rather making the Lightning error visible - was caused by check-in for Bug 1039162.
Pushed to comm-central changeset 8926fb06f635
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.5
Backported to releases/comm-aurora changeset f5a6cda17edf
Target Milestone: 3.5 → 3.4
The problem also exists on http://mxr.mozilla.org/comm-release/search?string=interaces

Maybe we should fix it there too in case we will do an 3.3.* release.
Yes, we should pick this up for 3.3.x if such a release is needed. Might as well push this to comm-release so its picked up automatically.

https://hg.mozilla.org/releases/comm-release/rev/2ded2e83d74f
Target Milestone: 3.4 → 3.3.1
You need to log in before you can comment on or make changes to this bug.