Closed Bug 1041589 Opened 8 years ago Closed 8 years ago

Show application title in status bar

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1042083

People

(Reporter: daleharvey, Assigned: etienne)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
I feel like this is the first piece of standalone work that can be done as part of incrementally landing the rocketbar into master.

There may be a dependency on prioritising the status bar icons so it can fit both the important icons as well as a title
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042083
Attached file Fat gaia PR
Here we go.

Currently this is a fat PR (because I want to iterate on try with the whole), but as you can see it's already organized in commit so it should make the review/breaking into smaller bugs easy.
Assignee: nobody → etienne
Attachment #8461033 - Flags: review?(kgrandon)
Attachment #8461033 - Flags: review?(alive)
Comment on attachment 8461033 [details] [review]
Fat gaia PR

Hey Etienne - this is looking pretty good to me. Any chance you could fix the statusbar issues on the homescreen? When I first launch it, the statusbar should be transparent, and as I scroll it should fade to black. Or am I missing some setting?
Attachment #8461033 - Flags: review?(kgrandon)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Comment on attachment 8461033 [details] [review]
Fat gaia PR

It seems appTileBar is not instantiated in this patch. What's the plan?
I could accept that to review your + vivien's patch at the same time but not one feature in two patches :/ Hard to understand without explanation.

About the global-search-request, I wonder if we could deprecate AppWindowManager and Rocketbar as I commented.
Attachment #8461033 - Flags: review?(alive)
Dale: ha sorry, I'll split the PR and move it to the correct bugs :)
Kevin: we definitely don't want to regress this, and it shouldn't will take a look.
Alive: I'll address your comments ASAP, and hopefully with the PR split into separate bugs it will be clearer.

Thanks all!
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042083
You need to log in before you can comment on or make changes to this bug.