[Search/Rocketbar] Color Matching Status Bar

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Search
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: epang, Assigned: mikehenrty)

Tracking

(Depends on: 2 bugs)

unspecified
2.1 S3 (29aug)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.1, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe][tako])

User Story

Visual Spec

https://bug1041625.bugzilla.mozilla.org/attachment.cgi?id=8475919

Attachments

(11 attachments, 4 obsolete attachments)

(Reporter)

Description

3 years ago
This bug is to track the work that needs to be done for the colour matching status bar.
Created attachment 8460033 [details]
Visual Spec
User Story: (updated)
Depends on: 1041896
Depends on: 1041898
Depends on: 1041899
Depends on: 1041900
Depends on: 1041901
Depends on: 1041902
Depends on: 1041903
Depends on: 1041904
Depends on: 1041905
Depends on: 1041908
Depends on: 1041909
Depends on: 1041910
Depends on: 1041911
Depends on: 1041912
Depends on: 1041916
Depends on: 1041918
Assignee: nobody → mhenretty
feature-b2g: --- → 2.1
Whiteboard: [systemsfe] → [systemsfe][tako]
Target Milestone: --- → 2.1 S1 (1aug)
Comment on attachment 8460033 [details]
Visual Spec

Eric, Diego pointed out that this spec doesn't have the actual colors for the status bar in them. Are we missing part of the spec?
Flags: needinfo?(epang)
(Reporter)

Comment 3

3 years ago
(In reply to Michael Henretty [:mhenretty] from comment #2)
> Comment on attachment 8460033 [details]
> Visual Spec
> 
> Eric, Diego pointed out that this spec doesn't have the actual colors for
> the status bar in them. Are we missing part of the spec?

Hi Michael, I left out the colours of the status bar since they should be colour matched to the header.  With the spec'ed out overlay on top.

The only places I included the colours are on the homescreen (#000000) and browser (#ffffff) since these screens do not have headers and will not change.

Let me know if I'm not making sense :)
Eric
Flags: needinfo?(epang)
(In reply to Eric Pang [:epang] from comment #3)
> (In reply to Michael Henretty [:mhenretty] from comment #2)
> > Comment on attachment 8460033 [details]
> > Visual Spec
> > 
> > Eric, Diego pointed out that this spec doesn't have the actual colors for
> > the status bar in them. Are we missing part of the spec?
> 
> Hi Michael, I left out the colours of the status bar since they should be
> colour matched to the header.  With the spec'ed out overlay on top.
> 
> The only places I included the colours are on the homescreen (#000000) and
> browser (#ffffff) since these screens do not have headers and will not
> change.
> 
> Let me know if I'm not making sense :)
> Eric

Can you do the calculations for us, and provide the RGB or hex values in the spec? Each app can only specify a final statusbar color, and so making it black with an opacity adds complication (ie, does the statusbar always overlap the header, what happens when the header goes away, etc.).
Flags: needinfo?(epang)
(Reporter)

Comment 5

3 years ago
Created attachment 8464554 [details]
Updated Visual Spec.jpg

Hi Michael,

I've updated the spec so that the hex values are used (instead of the overlay).

Let me know if you have any questions or need anything else.

Thanks!
Attachment #8460033 - Attachment is obsolete: true
Flags: needinfo?(epang) → needinfo?(mhenretty)
Looks good to me, thanks Eric!
Flags: needinfo?(mhenretty)
Depends on: 1047169
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)
Created attachment 8470321 [details]
[Visual Spec] now with callscreen

Updated Visual Spec
Attachment #8464554 - Attachment is obsolete: true
Depends on: 1052795
Eric, based on https://bugzilla.mozilla.org/show_bug.cgi?id=1041896#c9, the statusbar will automatically add a 0.1 opacity black overlay to the color we specify for theme. Can you update the spec to take this into account?
Flags: needinfo?(epang)
(Reporter)

Comment 9

3 years ago
Created attachment 8475919 [details]
[Visual Spec] now with callscreen and Market Place

Hey Michael,

I've updated the spec to take into account the 10% black overlay.
Pretty much all screens have changed besides the ones with a black status bar.

I've also realized that I should have added Market Place.  It's now in the spec and uses the same status bar as settings.

Let me know if anything else is needed, thanks!
Flags: needinfo?(epang)
(Reporter)

Updated

3 years ago
Attachment #8470321 - Attachment is obsolete: true
Depends on: 1056257
User Story: (updated)
(Reporter)

Comment 10

3 years ago
Created attachment 8476849 [details]
[Visual Spec]

latest visual spec
Attachment #8475919 - Attachment is obsolete: true
Depends on: 1057132
Target Milestone: 2.1 S2 (15aug) → 2.1 S3 (29aug)
The only work left to do here is in the callcreen. However, that relies on the attention window [1] which is not 2.1 blocking. Although it's being actively worked on, it is unlikely that will land in time for us to make the changes necessary to the callscreen app to close that by FL. I'm going to call that a polish bug, and close this user story since it is done except for callscreen (which was added to the spec late in the game anyway).

1.) https://bugzilla.mozilla.org/show_bug.cgi?id=1052795#c3
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: --- → fixed
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
Depends on: 1062326
Depends on: 1065421
Depends on: 1065420
Depends on: 1065419
Depends on: 1065960
Depends on: 1055746
Depends on: 1071706
Depends on: 1074352
Depends on: 1076258
Depends on: 1081356

Comment 12

3 years ago
Created attachment 8531882 [details]
Active Call

Hi Mike,
Could you help with it, thanks.
This issue has been verified unsuccessfully on Flame 2.1
The status bar do not show at active all page.
See attachment: Active Call.png
Reproducing rate: 5/5
Flame 2.1 versions:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141203.034907
FW-Date         Wed Dec  3 03:49:18 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(mlien)

Comment 13

3 years ago
Created attachment 8531884 [details]
Homescreen

Comment 14

3 years ago
Created attachment 8531885 [details]
Productivity

Comment 15

3 years ago
Created attachment 8531886 [details]
Comms

Comment 16

3 years ago
Created attachment 8531888 [details]
Media

Comment 17

3 years ago
Created attachment 8531889 [details]
Browser

Comment 18

3 years ago
Created attachment 8531890 [details]
Settings

Comment 19

3 years ago
Created attachment 8531892 [details]
Packaged / Hosted App

Comment 20

3 years ago
Created attachment 8531893 [details]
System Tray

Comment 21

3 years ago
Created attachment 8531895 [details]
Market Place

Comment 22

3 years ago
refer to comment 11, callscreen is the exception one
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
Flags: needinfo?(mlien)
Depends on: 1109196
You need to log in before you can comment on or make changes to this bug.