If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Clicking on submit button causes layout error in table

RESOLVED DUPLICATE of bug 103127

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 103127
16 years ago
16 years ago

People

(Reporter: David M. Karr, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011009
BuildID:    2001100903

I have a table (border="1") with two rows (and a header) where each "tr" is in a
"form", and where the last column has a submit button.  I notice that on initial
display, the distance between the bottom table border and the border around the
bottom two fields is a litle larger than the distance on the top of the table.

If I position my mouse cursor so it's on the very top of the bottom submit
button, and then click, a funny thing happens.

First, I see the button that I just clicked move down 2-3 pixels.  I also see
the bottom border of the table move up 2-3 pixels.  In addition, the form does
not get submitted.

If I instead position the mouse cursor closer to the center of the button and
then click, I see the same thing happen, but it appears that the form gets
submitted, and the page redisplays (to the original state) right after the funny
stuff.  Since my forms have no "action" attribute, the page should just
redisplay on submit.
This page was simplified from a more complex page, with more rows.  I found that
with more rows, and clicking on the bottom button, the distance the submit
button "jumps down" is larger.  If I instead remove as many rows as possible,
including the header, the behavior still occurs, but it's harder to get it to
happen, because the margin you have to click in to get the behavior is smaller,
perhaps one pixel.


Reproducible: Always
Steps to Reproduce:
1. Display the given page
2. Position the mouse cursor on the very top of the bottom submit button.
3. Click the mouse.

Actual Results:  The submit button jumps down 2-3 pixels, and the bottom border
of the table jumps up a similar distance.

Expected Results:  The form should submit and redisplay the page.

As I add more rows to the table, clicking on that spot on the bottom button
makes it jump down farther.

I'll enclose the contents of my HTML file here:
-------------------------
<html>
  <head>
   <title>List Classes</title>
  </head>
  <body>
   <table border="1">
    <tr><th>ID</th><th>Teacher</th></tr>
    <form name="editClassForm" method="POST">
    <tr>
     <td>eng102</td>
     <td>dkarr</td>
     <td><input type="submit" name="submit" value="Edit"></td>
    </tr>
    </form>
    <form name="editClassForm" method="POST">
    <tr>
     <td>cs101</td>
     <td>mdkarr</td>
     <td><input type="submit" name="submit" value="Edit"></td>
    </tr>
    </form>
   </table>
  </body>
</html>
-------------------------

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 103127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.