FxA refreshAuth prompt not brought up if disabling while registering

RESOLVED WONTFIX

Status

Firefox OS
FindMyDevice
RESOLVED WONTFIX
4 years ago
2 months ago

People

(Reporter: Kate Glazko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8459699 [details]
FMD Auth Prompt Not Brought Up on First Disable after Reboot

STR:

Flame 2.0.0., tested on maximum memory.
- Reboot device (using Erase from FMD, Wipe from Device Info, or Flash)
- Sign into FxA Account
- Go to Settings: FMD, enable FMD, verify FMD is enabled
- Toggle the bar to disable FMD


Expected: FxA Auth prompt will be brought up

Actual: Checkbox grays out for a while, and then FMD gets disabled without entering password.

Why this isn't an edge case: A lot of people may enable FMD once and only once and never think about it again until they lose their device, after which a thief might just try to disable FMD and be successful without a password.
(Reporter)

Comment 1

4 years ago
Logcat attached to link: https://pastebin.mozilla.org/5587323
I can see from the log that you attempted to disable FMD while it was still contacting the server to do the initial registration; a conflict between the two processes caused FMD to be registered but disabled at the end.

To be clear, this bug will only happen if you try to disable FMD while it is registering, during the first time you enable it. After registering, rebooting the phone will not cause this bug to appear -- you will get prompted to enter your password as expected. So I'd say this is indeed a corner case, though of course it's worth fixing.
Summary: FxA Auth Prompt Not Brought Up on Disable on First Disable Attempt After Reboot → FxA refreshAuth prompt not brought up if disabling while registering
Just a note - I ran into a similar bug caused by push failures, that's another scenario in which this can occur

Comment 4

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.