Closed Bug 1041661 Opened 5 years ago Closed 5 years ago

animation of transform on elements in pattern doesn't work -- It used to.

Categories

(Core :: SVG, defect)

24 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 975757
Tracking Status
firefox31 --- affected
firefox32 --- affected
firefox33 --- affected
firefox34 --- affected
firefox-esr24 --- affected
firefox-esr31 --- affected

People

(Reporter: david.dailey, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

http://srufaculty.sru.edu/david.dailey/svg/svgopen2008/patternTile3.svg


Actual results:

I believe this used to work fine in Firefox. It behaves as expected in Chrome (except for minor transparency issue); ASV, old Opera.

Sometimes, the animation seems to advance a few frames on mouseclick.


Expected results:

The elements inside the pattern should rotate.
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/308ecd2dcba2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130525 Firefox/24.0 ID:20130525204232
Bad:
http://hg.mozilla.org/mozilla-central/rev/0fed3377c839
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130525 Firefox/24.0 ID:20130525210635
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=308ecd2dcba2&tochange=0fed3377c839


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ff4d7b275942
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130524 Firefox/24.0 ID:20130524061652
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/50a7acb8c2ca
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130524 Firefox/24.0 ID:20130524072150
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ff4d7b275942&tochange=50a7acb8c2ca

Suspect: 
9ba223470c83	Jonathan Watt — Bug 875175 - Stop continuous reflow and invalidation of entire SVG when an element that is partially/wholly outside the viewport is subject to a transform animation. r=dbaron
Blocks: 875175
Status: UNCONFIRMED → NEW
Component: Untriaged → SVG
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Version: 30 Branch → 24 Branch
Am not sure if this is the same thing or not, but it has similar code, and, I believe, used to work in FF (version unknown):
http://srufaculty.sru.edu/david.dailey/svg/SVGOpen2008/barberPole.svg
(In reply to david.dailey from comment #2)
> Am not sure if this is the same thing or not, but it has similar code, and,
> I believe, used to work in FF (version unknown):
> http://srufaculty.sru.edu/david.dailey/svg/SVGOpen2008/barberPole.svg

This is not a not same bug. Because regression range is different.
Please file a new bug.
Flags: needinfo?(david.dailey)
(In reply to david.dailey from comment #2)
> Am not sure if this is the same thing or not, but it has similar code, and,
> I believe, used to work in FF (version unknown):
> http://srufaculty.sru.edu/david.dailey/svg/SVGOpen2008/barberPole.svg

aha,
You have already filed as Bug 975757.
Flags: needinfo?(david.dailey)
Patch in bug 975757 fixes this. It's basically the same issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 975757
You need to log in before you can comment on or make changes to this bug.