When changing tabs between two full-page-zoom'ed tabs, only upper-left region gets invalidated

RESOLVED DUPLICATE of bug 1041200

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1041200
4 years ago
4 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:
 0. Have a debug build (I've only reproduced this in debug builds, so far; not in nightly)

 1. Load these two URLs, in adjacent tabs:
  data:text/html,<div%20style="height:100%;width:100%;background:lime">abc
  data:text/html,<div%20style="height:100%;width:100%;background:red">abc

 2. Use "Ctrl +" to zoom in a few times in each tab (doesn't necessarily have to be the same amount)

 3. Switch back and forth between the tabs.

ACTUAL RESULTS: Only an upper-left area of the tab is repainted. (The higher the zoom-level, the smaller the area)
Hmm; I can reproduce this on my desktop machine at work (in two different debug builds), but not on my laptop.

[Removing a few local-hacks-that-I-don't-expect-to-influence-behavior to see if they might be responsible...]
Never mind, I can reproduce this on both my desktop and my laptop, with a TBPL-generated debug build from:
 https://tbpl.mozilla.org/?rev=0dc711216018
 http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux64-debug/1405947507/

...and with the opt build from the same cset:
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux64/1405947507/

So I'm guessing this is just a very-recent regression.
Keywords: regression
Created attachment 8459842 [details]
screencast

Here's a screencast of the bug, using the opt m-c build from TBPL mentioned in previous comment.
Keywords: regressionwindow-wanted
(Paint flashing confirms that only the upper-left region is getting repainted -- as you might expect, based on the symptoms displayed in the screencast)
(I initially thought this might be due to OMTC, since that was briefly turned on and then off today, in bug 994541.  But I don't think that's responsible, because layers.offmainthreadcomposition.enabled is set to 'false' (by default) in the build I'm testing.)

Comment 6

4 years ago
Maybe duplication of Bug 1041200
Yup, looks a lot like it, based on the symptoms. Thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1041200
You need to log in before you can comment on or make changes to this bug.