Closed Bug 1041754 Opened 6 years ago Closed 2 years ago

Add ability to search individual sites through the Awesome Bar.

Categories

(Firefox :: Address Bar, defect, P3)

x86
All
defect
Points:
13

Tracking

()

RESOLVED DUPLICATE of bug 782557

People

(Reporter: sevaan, Unassigned)

References

Details

Attachments

(1 file)

Currently a user can type search terms into the Awesome Bar which takes them to a results page on their default search engine's site.

Sometimes, however, users may want to search a specific site, such as Amazon.com.

This bug is about enabling users to do that in the Awesome Bar.

By typing a domain + a space + search query, the Awesome Bar's "searching for" row text will change to: Searching <Domain> for <Search Term(s)>

The Identity block will also change to reflect the domain that is being searched.

The user can exit site search by pressing the delete key after their search term/phrase is deleted.

If a user as a prior entry in their history related to a search on the user-selected domain, that will be listed as a result under the search suggestions.
Flags: firefox-backlog+
OS: Mac OS X → All
Some clarification: this is not the same as search keywords.

Putting »amazon.com firefox« into the awesomebar and pressing enter will expand to »site:amazon.com firefox« in your default search provider.
might depend on bug 951624 but there's no reason this should block it, unless I'm missing something.  Sounds more like an enhancement to build on top of that.
No longer blocks: 951624
Depends on: 951624
Flags: qe-verify?
Will we no longer show results from history for that domain? That seems counterintuitive...

For instance, I regularly visit: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/

The easiest way for me to get there is to type "ftp.mozilla.org nightly".

The mockup here doesn't let me do that - it'd take me to a <searchengine> search for "site:mozilla.org nightly" which is not what I want (and likely won't have this result).
Flags: needinfo?(sfranks)
I think this is only about the first row of the autocomplete that will be "special" preselected, you can still go down and use the first history result. I think the mock-up is missing the next entries there
Marco is right, the next entries are missing from the mockup. Thanks for calling attention to it.
Flags: needinfo?(sfranks)
Bug 951624 has been broken down, so we have some more specific dependencies here:
* bug 1065265 and bug 1065303 for the general infrastructure needed for this (both near landing)
* bug 1054914 to allow hitting delete
Depends on: 1065265, 1065303, 1054914
No longer depends on: 951624
Points: --- → 13
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 782557
You need to log in before you can comment on or make changes to this bug.