Closed Bug 1041779 Opened 6 years ago Closed 6 years ago

[Messages][MMS] Download button styles are broken

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S1 (1aug)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: azasypkin, Assigned: arnau)

References

Details

(Keywords: regression)

Attachments

(4 files)

Looks like patch from bug 1036147 added new "min-height" and "line-height" for buttons inside lists, so that Download button now looks ugly.
Arnau, can you have a look at it? Thanks a lot!
Flags: needinfo?(rnowmrch)
blocking-b2g: --- → 2.0?
Assignee: nobody → rnowmrch
Flags: needinfo?(rnowmrch)
Attached file patch in github
Sorry guys, Oleg was right this is a regression caused by bug 1036147.
I tried to review all buttons in gaia, but some of them (like this one) are difficult to catch even with QAwanted :)
Attachment #8460047 - Flags: review?(felash)
Comment on attachment 8460047 [details] [review]
patch in github

Oleg will review :)
Attachment #8460047 - Flags: review?(felash) → review?(azasypkin)
Triage feels this isn't a blocker because there's no apparent user impact to this bug & the visual impact feels minor.
blocking-b2g: 2.0? → backlog
[Blocking Requested - why for this release]:

This is a Visual Refresh bug. I think Visual Refresh is a feature for v2.0, so since it's a bug for a feature it should be a blocker.

If approvals can still be asked I'm fine with doing an approval though.
blocking-b2g: backlog → 2.0?
Comment on attachment 8460047 [details] [review]
patch in github

Now it looks good, thanks!
Attachment #8460047 - Flags: review?(azasypkin) → review+
Merged: 15c84c943e41ad834640a45e1e1c2ac804168af7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Julien

Please take the approval route here.
Flags: needinfo?(felash)
Oleg, I'll leave you request an approval for v2.0 here :)
blocking-b2g: 2.0? → ---
Flags: needinfo?(felash) → needinfo?(azasypkin)
Comment on attachment 8460047 [details] [review]
patch in github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment] Requesting uplift to 2.0 as it is a part of Visual Refresh that is v2.0 feature.
[Bug caused by] (feature/regressing bug #): Bug 1036147
[User impact] if declined: User will see misaligned "Download" button for MMS that wasn't downloaded automatically
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low, targeted small SMS specific CSS only change
[String changes made]: N/A
Attachment #8460047 - Flags: approval-gaia-v2.0?
Flags: needinfo?(azasypkin)
Attachment #8460047 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0?(lmandel)
Comment on attachment 8460047 [details] [review]
patch in github

Was really on the fence for this one, as this is not a blocker but given the super low risk and manageable risk and keeping in mind the visual refresh work for 2.0 approving this.
Attachment #8460047 - Flags: approval-gaia-v2.0?(lmandel) → approval-gaia-v2.0+
(In reply to bhavana bajaj [:bajaj] from comment #12)
> Comment on attachment 8460047 [details] [review]
> patch in github
> 
> Was really on the fence for this one, as this is not a blocker but given the
> super low risk and manageable risk and keeping in mind the visual refresh
> work for 2.0 approving this.

Thanks :)
This issue has been verified successfully on Flame 2.0,2.1

See attachment: Verify_image.png
Reproducing rate: 0/5
Flame 2.0 versions:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/29222e215db8
Build-ID        20141203000201
Version         32.0
Flame 2.1 versions:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0
Status: RESOLVED → VERIFIED
Attached image Verify_image.png
You need to log in before you can comment on or make changes to this bug.