:hover pseudo class does not work on child of button element

RESOLVED DUPLICATE of bug 843003

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 843003
3 years ago
3 years ago

People

(Reporter: Andrei Oprea [mention me on andrei.br92@gmail.com], Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

143 bytes, text/html
Details
If you have a <span> element inside of a <button> you cannot style it using the :hover pseudo class. 

Example http://jsbin.com/kiyahuci/1/edit

According to MDN page on button [0] you should (phrasing content)

[0] https://developer.mozilla.org/en-US/docs/Web/HTML/Element/button
Component: General → DOM: Core & HTML
Product: Firefox → Core

Comment 1

3 years ago
Created attachment 8459881 [details]
testcase

This never ever worked in Gecko (and Presto FWIW)

Updated

3 years ago
Keywords: testcase
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 843003
You need to log in before you can comment on or make changes to this bug.