bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can't log in on the Flame

RESOLVED INVALID

Status

Firefox OS
FxA
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: ggp, Assigned: _6a68)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Today's Gecko PVT build, gaia master.

STR:
1) Flash gaia
2) Go to FxA's panel in the Settings
3) Try to log in with an existing account
4) Watch the 'Connecting' spinner for a while
5) Get presented with the Age verification
6) Verify your age
7) Get stuck in the 'Connecting' spinner

You will also get stuck 'Connecting' if you try to create an entirely new account.
(Reporter)

Updated

4 years ago
Component: FindMyDevice → FxA
(Assignee)

Comment 1

4 years ago
I don't get the Connecting spinner hanging, but I do see that existing accounts are treated as new/unknown accounts. Digging in now.
(Assignee)

Comment 2

4 years ago
haha, ok. I was getting this because I had flashed gaia onto device, and my /build/config/custom-prefs.js had my device pointed at stage:

    user_pref("identity.fxaccounts.auth.uri", "https://api-accounts.stage.mozaws.net/v1");

When I don't include that pref and flash my device, the bug isn't reproducible on master.

When I create a new account on staging, then reflash the device, I correctly hit the sign in flow, not the sign up flow.

I'm 99% sure this is just an artifact of the staging stack getting blown away in the past day.

Leaving open for the moment, but once I verify that staging has been torn down, I'll close as a non-issue.
(Assignee)

Comment 3

4 years ago
jrgm tells me that the DB hasn't been destructively modified in the past week.

I don't keep long-lived staging accounts, but kglazko's staging account is fine.

:ggp, do you have anything in your build/config/custom-prefs.js? If not, ping me with account details and we'll try to narrow further on what's happening.
Flags: needinfo?(ggoncalves)
(Assignee)

Comment 4

4 years ago
another data point - jrgm says in IRC that he's logged in using 2 older staging accounts without problems.

I haven't been able to repro the long 'Connecting...' wait at all. Maybe this was just a problem with ggp's network?
(Reporter)

Comment 5

4 years ago
It's working fine today :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ggoncalves)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.