Scratchpad's Find to select old search string

RESOLVED DUPLICATE of bug 1159001

Status

()

RESOLVED DUPLICATE of bug 1159001
5 years ago
3 years ago

People

(Reporter: daedalon, Unassigned, NeedInfo)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

1. Choose Find (Ctrl-F)
2. Type a "search string 1"
3. Press enter
4. Get a search result
5. Repeat steps 1-3: Choose find (Ctrl-F), type "search string 2", press enter


Actual results:

6. Did not get a search result; the new search string was added to the end of the old one, making the search string be "search string 1search string 2"

This happens only in Scratchpad (Mozilla editor).


Expected results:

6. Got a new search result; the new search string overwrote the old search string, because choosing Find (Ctrl-F) selected the old string

This is the behavior in Firefox and other products I use, Mozilla and non-Mozilla. Scratchpad (Mozilla editor) is one of the few exceptions who don't yet select the old search string.

Comment 1

3 years ago
This was fixed by bug 1159001. (In case it's not fixed for you, reopen this bug)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(daedalon)
Resolution: --- → DUPLICATE
Duplicate of bug: 1159001
You need to log in before you can comment on or make changes to this bug.