Keyboard JS marionette test failure: Show Keyboard App after uninstallation

RESOLVED FIXED in 2.1 S1 (1aug)

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rudyl, Assigned: kgrandon)

Tracking

unspecified
2.1 S1 (1aug)
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Created attachment 8460130 [details]
permission_dialog.png

example failing job on Travis, https://travis-ci.org/mozilla-b2g/gaia/jobs/30533128
===
1) Show Keyboard App after uninstallation "before each" hook:

Error: timeout exceeded!

at Object.Client.waitForSync (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:682:16)

at Object.Client.waitFor (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:650:60)

at Object.System.waitForKeyboardFrameDisplayed (/home/travis/build/mozilla-b2g/gaia/apps/keyboard/test/marionette/lib/system.js:41:12)

at Context.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/keyboard/test/marionette/uninstallation_test.js:94:12)

at callFn (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:223:21)

at Hook.Runnable.run (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:216:7)

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:258:10)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:270:7

at done (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:185:5)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:199:9

at Object.executeHook (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:369:18)

at process._tickCallback (node.js:415:13)


I think this test failure is caused by keyboard is covered by a permission dialog of Collection app.
This could be reproduced locally, and I think this started to fail after bug 1038578 was landed.
Blocks: 1038578
(Assignee)

Comment 2

4 years ago
Created attachment 8460173 [details] [review]
Github pull request

Hey Guys - have a few minutes to review? There is one homescreen part, and one keyboard test part. Thanks!
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Attachment #8460173 - Flags: review?(rlu)
Attachment #8460173 - Flags: review?(amirn)

Updated

4 years ago
Attachment #8460173 - Flags: review?(amirn) → review+
(Assignee)

Comment 3

4 years ago
Comment on attachment 8460173 [details] [review]
Github pull request

Turns out there is only a homescreen part, so let's just go with amirs review. Thanks!
Attachment #8460173 - Flags: review?(rlu)
(Assignee)

Comment 4

4 years ago
Master: https://github.com/mozilla-b2g/gaia/commit/536bf5e660d42b7ba37ed37f81007f4f906ee6ba
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Kevin, Amir,

Thanks for your help to address this issue so quickly!
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S1 (1aug)
You need to log in before you can comment on or make changes to this bug.