Sidebar Search tab: Unable to type into textbox

VERIFIED WORKSFORME

Status

P1
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: boullet.marc, Assigned: samir_bugzilla)

Tracking

(Blocks: 1 bug, {qawanted})

Trunk
mozilla0.9.7
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
when clicking in the textbox of the sidebar Search tab,
focus is gained (at least a caret starts blinking) but
it is impossible to enter anything in the textbox.

BuildID 2001101003

Comment 1

17 years ago
claudius = qa_contact.
QA Contact: sujay → claudius
Summary: Sidebar Search tab: Unable to type into textbox → Sidebar Search tab: Unable to type into textbox

Comment 2

17 years ago
Tracy/Claudius, pleae try on latest trunk build...thanks.

Comment 3

17 years ago
sujay,  I have no problem typing in the search field and/or running searches 
from sidebar(windows and linux trunk builds from this morning)  

Comment 4

17 years ago
Marc, this works for us on both branch and trunk builds..

Can you re-install and try again?
(Reporter)

Comment 5

17 years ago
Ok, it is not as simple as I wrote.
Steps to reproduce:
1. restart browser from scratch
2. Once the browser started, if you type something in the
search textbox, it works. You're right.
3. Now change the search engine from dmoz.org to Google
4. Go back to the textbox. Blocked !!!!!!

Comment 6

17 years ago
Marc is correct... after change the search engine in the sidebar "using", one 
can no longer type in the search field.  I have my pref set to google search and 
tried switching to netscape search...it fails.  Switch back to google..still 
fails in typing into search field

changing platform to all.  I see this on linux also.
OS: Windows NT → All
Hardware: PC → All
(Reporter)

Comment 7

17 years ago
Just launched 20011011. Same behaviour
Note also that, after restarting the browser, for the
change of search engine I mentionned in step 3, the first
click on the dropdown "little arrow" is inoperant.
You have to click twice. After that, the dropdown list seems
hot enough and the button fires at the first click.
Maybe it's another bug.

Updated

17 years ago
Blocks: 64451
(Assignee)

Comment 8

17 years ago
I see this regression even with the 2001100903 build on my Win2K box but not on
the 0.9.4 branch builds.

Sujay,
Could you please narrow down between which two builds this regression first
occured?  Also, is this a problem for other dialogs with text edit field
widgets?  Thanks.
Severity: normal → major
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
Target Milestone: --- → mozilla0.9.6

Comment 9

17 years ago
Samir, this is a search bug...Claudius will take a look at this...

thanks..
(Assignee)

Comment 10

17 years ago
Claudius,
Can you help out in narrowing down when this regression was first introduced? 
Thanks.
~Samir
Component: Sidebar → Search

Comment 11

17 years ago
The textbox isn't getting any oninput commands.
When you open up the tab again it works ok.

Comment 12

17 years ago
*** Bug 105591 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
this works for me now with 20011025 builds on all platforms. marking WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 14

17 years ago
marking VERIFIED WFM. feel free to reopen if you can prove otherwise.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

17 years ago
I don't agree with this WFM.
I'm still seeing this bug on 2001102603.
To reproduce, just do the search engine switch just after
browser launching.

Reopening.

Note that, once blocked, if you select another tab and go
back to search, it works (as per matt comments 10-12 15:17)
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED

Comment 16

17 years ago
I stand corrected. Good catch Marc. I misreported my build ID. I can reproduce
this bug on a 2001103108 Win98 build (among others).

Samir, I don't have _any_ trunk builds during the likely time this regression
was introduced so it'll take quite some time to narrow down.
I've only managed to pin it between a 2001091409 build and a 2001092522 build.

If anyone has spare cycles and wants to do a quick binary search that'd be great.

I also noticed the click twice to open the dropdown quirk that Marc noted also
occured in every case.
Keywords: qawanted
(Assignee)

Comment 17

17 years ago
Plan on landing early in mozilla0.9.7.
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 18

17 years ago
This doesn't work for me in a 2001-10-21-21-trunk build on Win2K but doe swork
for me in today's 2001-11-29-03-trunk build.  In addition, I had to click only
once on the dropdown for the engine list to popup.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 19

17 years ago
Claudius, please verify....thanks.
(Assignee)

Comment 20

17 years ago
*** Bug 113389 has been marked as a duplicate of this bug. ***
verified 2001-12-17 commercial builds
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.