Sidebar automatically opens a few millimeters when reloading a page

VERIFIED FIXED in Future

Status

SeaMonkey
Sidebar
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Mitch, Assigned: Samir Gehani)

Tracking

({helpwanted})

Trunk
Future
Sun
Solaris
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Needs investigation on solaris, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Go to

    http://bugzilla.mozilla.org/buglist.cgi?bug_status=NEWCONFIRMED

Close the sidebar from the browser completely (uncheck View->Sidebar or
use F9 key)

reload the page using the reload button in the browser. 

The sidebar opens automatically by about 1cm.

I am using Modern Theme.

Happens with 0.95+ mozilla build 2001101022 but NOT on
0.94+ build 2001100622. Seems to be a new bug crept in..

Comment 1

17 years ago
I'm tied up with 0.9.4 branch testing...Samir, can you 
look at this? looks like a regression in 0.9.5

Comment 2

17 years ago
forgot to mention that I cannot reproduce this on 0.9.4 branch build.
(Assignee)

Comment 3

17 years ago
Can't reproduce with a 0.9.5+ 2001101103 Win2K build.  What platform are you
seeing this on?  Solaris (or was that just the platfor you filed this bug from)?  

Sujay,
Do we see this on Linux?
(Assignee)

Updated

17 years ago
Whiteboard: Needs investigation

Comment 4

17 years ago
works for me on linux trunk builds (10/11) using Modern theme...
I have not tried 0.9.5 branch...

(Assignee)

Comment 5

17 years ago
Can't reproduce this even on a 2001101022 Solaris 2.6 build.  If there are
additional steps or conditions that will help us reproduce this please reopen
with the additional info.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Whiteboard: Needs investigation → Needs investigation on solaris
(Reporter)

Comment 6

17 years ago
Yup only confirmed to fail on Solaris so far with the 0.9.5+ branch.
Here is what "about:" says (i downloaded the latest build and it still
fails)

Mozilla 0.9.5+
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.5+) Gecko/20011011 
Status: RESOLVED → UNCONFIRMED
OS: SunOS → Solaris
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

17 years ago
Created attachment 53239 [details]
Image showing problem
(Reporter)

Comment 8

17 years ago
Attached an image of the problem when i closed the sidebar and then loaded
the URL mentioned. See the sidebar opened a slight cm or so ?

Also, the problem is not Theme specific as i tried with the "Classic" theme
and the problem still persists. Again this is on the 0.9.5+ branch. Cannot
reproduce on 0.9.4+ series.

Comment 9

17 years ago
I can confirm this on Solaris build 2001101122, though the behavior that I'm
seeing seems a little bit different.

I usually have my sidebar close.  When I go to the url referenced, I opened up
my sidebar with F9, let the sidebar load completely, and then closed it with F9.
 Then when I hit reload, my sidebar opens back up to its normal width.

I haven't been able to reproduce this bug on any other type of page except
Bugzilla bug.cgi pages.  It doesn't show up on bug query pages or show_bug.cgi
pages. It also does not show on several other ordinary pages or cgis that I tried.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

17 years ago
Only observed on Solaris so far (and that too it is not reproducible for
everyone).  Thus, futuring.
Keywords: helpwanted
Target Milestone: --- → Future
(Reporter)

Comment 11

17 years ago
Doesn't happen anymore on newer builds of mozilla.

I am marking as closed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
verified per comments.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.