[PP] [Blocker] regression, can't launch Apprunner

VERIFIED FIXED in M9

Status

P3
blocker
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: pmock, Assigned: sfraser_bugs)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Build Date & Platform Bug Found:
 Mac commercial seamonkey build 1999-07-23-09-m9 installed on PPC 9600/300
running Mac OS 8.5.1 and G3 400mhz running Mac OS 8.6

Overview Description:
 Apprunner crashes to Macsbug on launch.  You crash when your finish running the
Profile Manager.  You crash if you try to re-launch apprunner.  You crash if you
try to use the -mail parameter to launch apprunner.

Note: this is a regression from yesterday build 1999-07-22-08-m9.  This problem
does not occurs on today win32 or linux builds

Steps to Reproduce:
0) Removed my mozregistry preference
   Removed my previous provile
1) Launch Apprunner
   The profile wizard appears
2) Click on the next button then type in a profile name and click Finish
   Apprunner crashes
3) Reboot
4) Launch Apprunner again
   Crashes to Macsbug

Actual Results:
 The crashes to Macsbug.

Expected Results:
 It should launch Apprunner successful and load the default browser page.

Additional Builds and Platforms Tested On:
  Win32 seamonkey build 1999-07-23-08-m9 installed on Gateway P200 Win98
  Linux seamonkey build 1999-07-23-09-m9 installed on Compaq P200 Redhat 5.2
The problem does not occur on these platforms.

Additional Information:
 Talkback Incident# are 11515720, 11615630, 11514264, and 11514035
 Go to http://cyclone

The Macsbug log is consistent.

 Macsbug log
 -----------

 The “apprunner” heap at 07905480 is ok
 Totaling the “apprunner” heap at 07905480
                                 Total Blocks    Total of Block Sizes
  Free                           0003       #3   002BA490     #2860176
  Nonrelocatable                 00EB     #235   006D8AAC     #7178924
  Relocatable                    0082     #130   00002B80       #11136
    Locked                       0003       #3   000002B0         #688
    Purgeable and not locked     0000       #0   00000000           #0
  Heap size                      0170     #368   00995ABC    #10050236
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  07907A34
  082E6DC0    PPC  07906DC4  main+00D94
  082E6BC0    PPC  07605678  nsAppShellService::Run()+00018
  082E6B80    PPC  07507294  nsAppShell::Run()+00038
  082E6B00    PPC  07507B34  nsMacMessagePump::DoMessagePump()+0003C
  082E6AB0    PPC  07507DEC  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00158
  082E6A60    PPC  07856B8C  Repeater::DoRepeaters(const EventRecord&)+00030
  082E6A20    PPC  078566AC  TimerPeriodical::RepeatAction(const EventRecord&)+
00048
  082E69D0    PPC  07856208  TimerImpl::Fire()+00024
  082E6990    PPC  0783B3BC  nsNetlibService::NetPollSocketsCallback(nsITimer*,
void*)+0001C
  082E6950    PPC  0781AECC  NET_PollSockets+0002C
  082E6900    PPC  07816800  NET_ProcessNet+003C4
  082E6570    PPC  078238B0  net_ProcessFile+00194
  082E6520    PPC  0783EEB0  stub_complete(_NET_StreamClass*)+00090
  082E6490    PPC  073420E0  nsDocumentBindInfo::OnStopRequest(nsIURI*, unsigned
int, const u
nsigned short*)+00040
  082E6440    PPC  07851EF4  nsUnicharStreamLoader::OnStopRequest(nsIURI*,
unsigned int, cons
t unsigned short*)+0001C
  082E6400    PPC  07389894
XULContentSinkImpl::DoneLoadingScript(nsIUnicharStreamLoader*, n
sString&, void*, unsigned int)+00048
  082E63C0    PPC  0746A728  nsParser::EnableParser(int)+00068
  082E6370    PPC  0746B258  nsParser::ResumeParse(nsIDTD*, int)+000A0
  082E6320    PPC  0746B3AC  nsParser::BuildModel()+00070
  082E62D0    PPC  07477F58  CWellFormedDTD::BuildModel(nsIParser*, nsITokenizer*
, nsITokenOb
server*, nsIContentSink*)+00078
  082E6280    PPC  07478884  CWellFormedDTD::HandleToken(CToken*, nsIParser*)+
002DC
  082E6170    PPC  07385DBC  XULContentSinkImpl::OpenContainer(const
nsIParserNode&)+00074
  082E6120    PPC  07388904  XULContentSinkImpl::OpenTag(const nsIParserNode&)+
00090
  082E5E00    PPC  0738973C  XULContentSinkImpl::OpenScript(const nsIParserNode&
)+00348
 Closing log
(Reporter)

Comment 1

20 years ago
Note: Paul Hangas and Jeff Ducarroz are working on problem.
(Reporter)

Comment 2

20 years ago
Adding sfraser to CC: list.
According to Jeff, Simon just fixed the problem.

Simon, could you review this bug?  Mark it fixed or a duplicate.  I couldn't find
an existing bug.
(Assignee)

Updated

20 years ago
Assignee: don → sfraser
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

20 years ago
I believe I just checked in fixes for this. There were problems resolving
chrome URLs, that were caused by some necko-related checkins.

Comment 4

20 years ago
Working for me with Simon's checkin.
(Reporter)

Updated

20 years ago
Summary: [PP] regression, can't launch Apprunner → [PP] [Blocker] regression, can't launch Apprunner
(Reporter)

Comment 5

20 years ago
Great work guy!:)  Waiting for next build before can verify.

Updated

20 years ago
QA Contact: leger → pmock
Target Milestone: M9

Comment 6

20 years ago
pmock,can you verify now?
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

20 years ago
Verified in the Mac Seamonkey build 1999-08-30-09-m10 and 1999-08-27-12-m10
builds

Apprunner launches fine.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.