Closed Bug 1042255 Opened 5 years ago Closed 5 years ago

Check for updates 24.6 in Help | About -- downloads and applies update without notice or consent

Categories

(Thunderbird :: General, defect)

24 Branch
x86_64
Windows 8
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 707489

People

(Reporter: educmale, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Opened help dialog, and clicked "check for updates"

Using TBird 24.6

1) -Without- my consent, the application not only checked, but it downloaded and reporting applying the update.

2) It then hangs (hung) ((for search purposes)) on "applying update".


Actual results:

After it hung with the timer and an "applying update" notice,

I closed the about dialog box, and then reopened it -- on reopening the about dialog, the application provided a button "restart to update".     Pushing that button requests permission to update [Win 8], then checks add-on and etc.   TBird appeared to work normally thereafter.   (only Lightning was updated, from 2.x to 3.3)


Expected results:

TBird should wait for me to grant permission to do any update steps beyond 'checking'.

When it does "apply the update" it should work to completion, and properly report a "restart to update", without hanging.
This got fixed in Thunderbird 31.
More exactly, patched in 29 and shipped public in 31.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Component: Untriaged → General
Resolution: --- → DUPLICATE
Summary: Check for updates 24.6 -- downloads and applies update without notice or consent → Check for updates 24.6 in Help | About -- downloads and applies update without notice or consent
Duplicate of bug: 707489
I just noticed....I have -NO- idea why I saw 24.6 as the version number on the dialog.  On reflection, I was using version 30 (at least...I thought I was....).  Is this a bug, or something else....?   There is no way for me to reproduce that quirk.
You need to log in before you can comment on or make changes to this bug.