If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Composer should not ask for alt text after every use of the same image window

VERIFIED INVALID

Status

SeaMonkey
Composer
VERIFIED INVALID
16 years ago
12 years ago

People

(Reporter: TucsonTester2, Assigned: Charles Manske)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build ID: 20011009

Composer should only ask one time to apply alt text for an image.

Reproducible: Always

Steps to Reproduce:
1.Open Composer
2.Click on the image button on the toolbar to and insert an image (do not add
any alt text)
3.Double-click on the image you just inserted
4.Click ok

Actual Results:
Instead of the window just closing it pops the alert to add alternative text.

Expected Results:
I would expect that composer would not ask me for the alternative text
everytime.  If at all possible maybe composer could automatically add the file
name for the alt text, if someone wants to add a description they can add one later.

Comment 1

16 years ago
over to charley, Charley we have talked about this several times...
Assignee: syd → cmanske
I feel that we should allow a blank string as valid alt text for an image. 
Sometimes, there is just no appropriate alt text....

Note: the filename is _not_ appropriate alt text.
(Assignee)

Comment 3

16 years ago
Kathy: Should we stick by our current efforts to encourage Alt text?
a) Alt text is clearly a *major* accessibility issue...
b) the W3C html validator will not validate a document w/o alt text for images

I strongly recommend a WONTFIX on this bug. Alternate text for images should
ALWAYS be properly set by web authors.
http://www.w3.org/TR/html401/struct/objects.html#adef-alt

    * Do not specify irrelevant alternate text when including images intended to
format a page, for instance, alt="red ball" would be inappropriate for an image
that adds a red ball for decorating a heading or paragraph. In such cases, the
alternate text should be the empty string (""). Authors are in any case advised
to avoid using images to format pages; style sheets should be used instead.

Another example is setting an arbitrary height and width on a 1px * 1px
transparent gif for spacing.  "transparent spacer set to 40x100px" is not
appropriate here and should again be the empty string.

We should *encourage* accessibility, but not force it down users throats.  It is
annoying to have to see the warning for every image with an empty string for the
alt text.  I propose to pop up the current recommendation once, but if the alt
text has already been set to the empty string, do not pop up the warning again
for subsequent usages of the same image's properties dialog.

It might also be considered to add a "Do not warn me again" checkbox on that dialog.

Marking NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

16 years ago
I think this should be INVALID; this functions as we expect.  

If users really don't want to have to be prompted nor take the time to add a good 
alt attribute, they can simply add a space and then they shouldn't be prompted.  

I don't think we should add a checkbox; that defeats the purpose and is just 
extra code for us to have to write, maintain, and test.
(Assignee)

Comment 7

16 years ago
As Kathy mentioned, adding a space is best "workaround".
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 8

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.