If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Restart Notice Jumps the Gun in ESR

RESOLVED DUPLICATE of bug 461007

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 461007
3 years ago
3 years ago

People

(Reporter: jamesg, Unassigned)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20140609182057

Steps to reproduce:

1. Have Firefox ESR version N running (ie 24.6)
2. Have all settings set to ask but do not apply
3. Have promulgation of N + 0.1 occur (ie 24.7)
4. The window asking if you want to apply the patch right now appears
5. Tell it to apply the patch later, or even just minimize the window, refusing to give it an answer.





Actual results:

Even though no update has been applied, and all care has been taken to prevent this result, all windows in all sessions display the incorrect, misleading, and irritating message: 

"Your browser has been updated and needs to be restarted."

Even though it has been very pointedly NOT updated, and restarting it without telling it to update will obviously not make this message go away.


Expected results:

This message should not be displayed, if at all, until the update has actually happened.

Comment 1

3 years ago
seem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461007
You need to log in before you can comment on or make changes to this bug.