[B2G][Browser] Zooming and panning a webpage while performing a app transition gesture causes buttons to stop functioning

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support] [2.0-exploratory], URL)

Attachments

(1 attachment)

Description:
Zooming and panning a webpage while performing a "app transition" edge gesture causes buttons to stop functioning. The "Close" and "Reload" buttons will not work after the browser has OOM and the lockscreen slider will also stop working. 

The user will have to pull their battery and re-power on their device to recover.

Prerequisite: No apps should be open on the device. Edge gestures should be enabled in settings.

Repro Steps:
1)  Updated Flame to Build ID: 20140721000201. Set the memory to 273mb.
2)  Tap on the "Browser" icon.
3)  Go to www.outlook.com
4)  Zoom and pan the webpage while performing the "app transition" edge gesture.
5)  Try to tap on the "Close" and "Reload" buttons after the OOM.
6)  Put the phone to sleep and then wake it back up. Try to slide the slider to unlock the phone on the lockscreen.

Actual:
Buttons will stop functioning if the user performs an "app transition" edge gesture while panning and zooming a webpage. The user will have to pull their battery and re-power on their device to recover.

Expected:
The user can pan and zoom a webpage while performing an app transition edge gesture without issue. Buttons are always functional even after an OOM.

Environmental Variables
Device: Flame v 2.0 (273mb) 
Build ID: 20140721000201
Gecko: https://hg.mozilla.org/releases/mozilla-aurora/rev/4bd4b0ae7bbe
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Platform Version: 32.0a2
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 80%
See attached: video clip, logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Kevin - Can you flag down a lead to do the QAnalyst-Triage review here?
Flags: needinfo?(ktucker)
This issue also occurs on the Flame 2.1(273mb).

When panning and zooming a webpage while performing the "app transition" edge gesture, the buttons "Close tab" and "Reload" will be non-functional after the OOM occurs. Also, the lockscreen slider will not work as well. The user will have to pull their battery and re-power on their device.

Flame 2.1(273mb)

Environmental Variables:
Device: Flame 2.1(273mb)
BuildID: 20140721062116
Gaia:
Gecko: 0dc711216018
Version: 33.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

-------------------------------------------------------------------------------------------

This issue does not reproduce on the Buri 2.1, Open C 2.1, Buri 2.0, Flame 2.0(512mb), Open C 2.0, Flame 1.4(273mb), Buri 1.4 and Open C 1.4.

The slider on the lockscreen and the buttons always function as normal.

Buri 2.1

v2.1 Environmental Variables:
Device: Buri Master
BuildID: 20140721062116
Gaia: Unknown
Gecko: 0dc711216018
Version:  33.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140721062116
Gaia: Unknown
Gecko: 0dc711216018
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140721003002
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0(512mb)

Environmental Variables:
Device: Flame 2.0(512mb)
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 1.4(273mb)

Environmental Variables:
Device: Flame 1.4(273mb)
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Flags: needinfo?(ktucker)
(Reporter)

Updated

4 years ago
Flags: needinfo?(jmitchell)
Created attachment 8460603 [details]
Nonfuncitonalbuttonslogcat.txt
[Blocking Requested - why for this release]: Nomming as a blocker - flow is feasible to hit with the average user (I find panning and zooming too near the screen edge often results in a transition gesture) and the bug state has a highly negative recover state (must remove battery)
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Just my two cents: based on the video and the fact that the lockscreen doesn't respond to touch events I would think this is a problem in the edge-swipe gesture detector. The lockscreen doesn't have APZ enabled and so touch events don't even get to the APZ code there. They only go through widget code and the root process touch event listeners, which include the edge-swipe gesture detector. It could be something else but that's where I would start looking.
QA, Can you check the to see if this happens with edge gestures turned off as well?

[based on comment 5]
Component: Gaia::Browser → Gaia::System::Window Mgmt
swapping regression-window tag for qa-wanted tag - see comment 6
Keywords: regressionwindow-wanted → qawanted
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #6)
> QA, Can you check the to see if this happens with edge gestures turned off
> as well?
> 
> [based on comment 5]

On the original build I am able to reproduce this issue with Edge gestures disabled.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

However, this issue no longer reproduces on the latest 2.1 Flame build and 2.0 Flame build on 319 MB


Device: Flame Master
BuildID: 20140725102306
Gaia: 3a06aa58245eaf848242d6d1497c1af536fffabd
Gecko: 8da875b402fe
Version: 34.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0
BuildID: 20140725124106
Gaia: 0a864988f5dce7f9f3dea9609e8ef054679c30ff
Gecko: c6ecb3501040
Version: 32.0 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
no longer repros in the new 319 mem, removing blocking flag but leaving open for perf investigation
blocking-b2g: 2.0? → ---
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
I cannot reproduce this on a 319mb flame running build id: 20140721000201.  I'm closing this as won't fix.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.