[B2G][Settings][Download] The "No Downloads" string does not appear.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Download
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: Dean R. Gomez (DeanG), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-flame-test-run-3] [2.1-flame-test-run-1] )

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8460646 [details]
No_Downloads.png

Description:
When there have been no downloads initiated on the device and the user navigates to the download manager within the settings app, the "No Downloads" string will be missing.

Repro Steps (Example for #1 in description):
1) Update a Flame to 20140721000201
2) Launch Settings > Downloads
3) Observe the screen with no downloads.

Actual:
The "No Downloads" string will be missing.
Expected:
The "No Downloads" string will appear clearly.

2.0 Environmental Variables:
Device: Flame 2.0 (273MB)
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 8/8 - 100%
See attached: Logcat_No_Downloads.txt, No_Downloads.png
(Reporter)

Comment 1

4 years ago
Created attachment 8460648 [details]
Logcat_No_Downloads.txt

Attaching logcat.
(Reporter)

Comment 2

4 years ago
This issue DOES occur on Flame 2.1 (273MB) and Open_C 2.0. 


Flame 2.1 (273MB)

2.1 Environmental Variables:
Device: Flame Master
BuildID: 20140721062116
Gaia: Unknown
Gecko: 0dc711216018
Version: 33.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Result: The "No Downloads" string will be missing.

-----------------------------------------------------------------------------------

This issue DOES NOT occur on  Flame 1.4 (273MB), Flame 2.0 (512MB), Buri 1.4, Buri 2.0, Buri 2.1, Open_C 1.4, and Open_C 2.1.


Flame 1.4

Environmental Variables:
Device: Flame 1.4 (273MB)
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Flame 2.0 (512MB)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140721000201
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140721003002
Gaia: 8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko: 4bd4b0ae7bbe
Version: 32.0a2 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 2.1

Environmental Variables:
Device: Buri Master
BuildID: 20140721062116
Gaia: Unknown
Gecko: 0dc711216018
Version:  33.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140721000201
Gaia: 621d152f89347c79619aa909ad62cc2ac9d3ab5b
Gecko: 83b7be7fb33f
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open_C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140721062116
Gaia: Unknown
Gecko: 0dc711216018
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Result: The "No Downloads" string appears clearly.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 3

4 years ago
Please note: The string "No downloads" appears after pre-downloaded files are deleted from the download manager.
This seems to be a low impact issue and the bug only occurs if the user has not downloaded a file before on their phone. Even though this is a regression from 1.4 not nominating this issue as a blocker.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
When there are no downloads, the DownloadApiManager.getDownloads() call in DownloadsList.init does not end up calling its first argument (the onsuccess callback argument, which we're passing _render in for).  Haven't looked further to see why.
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Whiteboard: [2.0-flame-test-run-3] → [2.0-flame-test-run-3] [2.1-flame-test-run-1]
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)

Updated

3 years ago
Component: Gaia::Settings → Gaia::System::Download

Comment 6

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.